Closed Bug 260131 Opened 17 years ago Closed 13 years ago

Adding/removing search terms when highlight all is enabled removes (deletes) highlighted text in some cases

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.1a2

People

(Reporter: danzcontrib, Unassigned)

References

()

Details

(Whiteboard: [fixed by bug 263683])

Attachments

(1 file)

308 bytes, text/plain
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.7+) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.7+) Gecko/20040707 Firefox/0.9.2

WHen you use the Fin bar with Highlight selected, you have strange results when
the second character is typed

Reproducible: Always
Steps to Reproduce:
1.Edit /Find in this page
2.type t
3.select Highlight then type h

Actual Results:  
the text from sentence two is modified
if you type e the the text seems to get back to its place
if you delete the e or add r the text is modified

Expected Results:  
Highlight the text without modifying it
in fact the User agent is
Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040911 Firefox/0.10

I also have problems with this page when using the Find bar and Highlight but it
doesn't scramble the text
Attached file Testcase
It seems related to the CSS style.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1

I'm not sure if these bugs are related but I get something similar at
http://java.sun.com/j2se/1.5.0/docs/api/java/awt/Scrollbar.html

Steps to reproduce:
- Scroll down to 'Methods inherited from class java.awt.Component'
- Press Ctrl+F to open the find box
- Enter 'size' and press Highlight several times

Actual results:
The links within the enclosing box skip out of it.

Expected results:
Simply highlight the words without changing the layout.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I still can see a bug with version 1.6a1 and
version 1.0.7
type
http://danzcontrib2.free.fr/constr_php.php
Edit / Find in this page
type the letter a for example
select highlight (all)
the text in <li> between <ul></ul> partially disappears :
with
n<span id="__firefox-findbar-search-id" style="background-color:
yellow;">a</span>vig<span id="__firefox-findbar-search-id"
style="background-color: yellow;">a</span>teurs

avig is not displayed
I think that an id (<span id="__firefox-findbar-search-id" ) cannot be used more
than once and that may be the origin of the problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051005
Firefox/1.6a1 ID:2005100515

Dan, I'm really not sure what the issue is here. Could you please attach a
screenshot of the "scambled" text that you see? This works as expected for me.
*** Bug 311177 has been marked as a duplicate of this bug. ***
Alright, now I see what you mean, Dan.
Assignee: firefox → nobody
Status: UNCONFIRMED → NEW
Component: General → Find Toolbar / FastFind
Ever confirmed: true
QA Contact: general → fast.find
Summary: Find bar and Highlight selected scambles the text → Adding/removing search terms when highligh all is enabled removes (deletes) highlighted text in some cases
Version: unspecified → 1.5 Branch
Summary: Adding/removing search terms when highligh all is enabled removes (deletes) highlighted text in some cases → Adding/removing search terms when highlight all is enabled removes (deletes) highlighted text in some cases
See bug 256990 and bug 256773 for more information; the latter is what really
needs to be done to fix this properly. I can't see this blocking at all, so it's
probably better to push for a trunk fix of bug 256773.
Depends on: 256773
Product: Firefox → Toolkit
This was most likely fixed by bug 263683.
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: 263683
Resolution: --- → FIXED
Version: 1.8.0 Branch → Trunk
Status: RESOLVED → VERIFIED
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [fixed by bug 263683]
Target Milestone: --- → mozilla1.9.1a2
No longer depends on: 256773
You need to log in before you can comment on or make changes to this bug.