without a special comment above the <doctype> the <div> layer can not be placed in a correct position.

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: info, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The source of http://www.browsertec.de/pub/demo_nok.html shows a normal XHTML
1.0 transitional doctype but the layer won't work.

The source of http://www.browsertec.de/pub/demo_ok.html shows the folowing
special comment above the XHTML 1.0 transitional doctype and the layer works
corrcet.

<!-- HEAD
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.1//DE" "../dtd/xhtml1-frameset.dtd">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
//-->
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

With the comments above the layer could be placed correctly. The error - no
placement available - occurs only in the firefox browser.
All demo-codes are W3C compatible.

Reproducible: Always
Steps to Reproduce:
1. open http://www.browsertec.de/pub/demo_nok.html in firefox
2. click one of the links top left

Actual Results:  
The position of the gray layer is in the top left corner and the layer could not
be placed via clicking a link.

Expected Results:  
The position of the layer should be on 150,300 Pixel and the layer should be
placed on the cursor position if you click on a link.
Try http://www.browsertec.de/pub/demo_ok.html, that works.

It seems that the doctype tag should be a correct one. If i use a HTML 4.0.1
Doctype the layer positioning works. But if i use a XHTML 1.1 doctype, the error
occurs.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> works

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> don't work
without special comment as follws:

<!-- HEAD
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.1//DE" "../dtd/xhtml1-frameset.dtd">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
//-->

With this comment it works.
If you just edit the last //EN"> to //DE"> the error occurs.

So i think its a very special problem with the XHTML 1.0 doctype interpretation
of the firefox browser. All other browsers i tested (IE, Opera, NS4) do not have
this error.

Please feel free to contact me via strecke@browsertec.de because we will
integrate your browser in our websolutions and i'm curious why this error occurs ;)

Comment 1

14 years ago
<div id='tooltip' style='position:absolute;left:150;top:300;visibility:visible;'>

You have to specify the position in pixels here.  Since you didn't the pages in
standards rendering mode (the not ok page) ignores it.

The comment junk you have on the ok page forces Mozilla into quirks rendering
mode, where it will assume you meant pixels.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Thanx, thats it, with "px" the placement works in both modes.
But the additional question: 
On which pattern he decides to switch into the quirks rendering mode? 
Because ... if i edit the junk comment above, he wouldn't switch. 
And how can i realize in which mode he is?
You need to log in before you can comment on or make changes to this bug.