Page loading fails with Content-Encoding: gzip

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Andreas Schwarz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

I have a server with Apache 2.0.51 and mod_deflate.

1. When I click on a link (e.g.
http://neu.mikrocontroller.net/wiki/Spezial:Randompage), every 5-10 requests I
get a download window instead of the page content. While the download window is
open, I can see the headers of the server response in the temporary file which
is created in the default download directory (attached).

2. When I reload a page (e.g. http://neu.mikrocontroller.net/wiki/AVR) a few
times, sometimes I can see the headers of the response instead of the rendered
page in the browser window (attached). The status bar still says "Transferring
data", but nothing happens.

Safari and Mac-IE have no problems with this server.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to http://neu.mikrocontroller.net/wiki/.
2.1. Click on the link "Zufälliger Artikel" (left nav. bar).
2.2. Repeat until you get a download window.
Actual Results:  
I get a download window after a few seconds delay.

Expected Results:  
The page should be displayed.

The text seen in the browser after reloading a few times (note the non-ASCII
char at the beginning):

(Reporter)

Comment 1

14 years ago
Created attachment 159274 [details]
The temporary download file.
(Reporter)

Comment 2

14 years ago
The "Additional Information" has been chopped by Bugzilla, probably because of
the non-ASCII data, so I have attached the temporary file for (1). The content
seen in the browser after reload (2) is similar.
(Reporter)

Comment 3

14 years ago
Created attachment 159304 [details]
This file is offered for download by Mozilla 1.8a, Linux.
(Reporter)

Comment 4

14 years ago
Could be reproduced with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20040917. A file is offered for download (see 2nd attachment).
(Reporter)

Comment 5

14 years ago
I have disabled mod_deflate for the URLs mentioned above.
New demonstration:
http://213.146.167.224/cgi-bin/test.rb

Press reload a few times, then you should see the raw HTTP response.
(Reporter)

Comment 6

14 years ago
The problem is independent of the Transfer-Encoding: chunked header.
Summary: Page loading fails with Transfer-Encoding: chunked & Content-Encoding: gzip → Page loading fails with Content-Encoding: gzip
(Reporter)

Updated

14 years ago
Severity: major → critical
Component: General → Networking: HTTP
OS: MacOS X → All
Product: Firefox → Browser
Hardware: Macintosh → All
Version: unspecified → Trunk

Comment 7

14 years ago
reproducable on public site:
http://www.dexonline.com/servlet/ActionServlet?pid=singlemappingresults&mq=Y&primaryBusinessRecordID=kct2ren4cnvoqmiqolcmenjgo&primaryHeadingID=394&primaryProductID=1012&last10Saved=true&resultForm=BASIC

I'm using
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The file shows up as a download and if I down load it I notice the content
encoding is gzip ... is this the same bug?
bug 227976?

does this work in deer park alpha 2?
Assignee: firefox → darin
QA Contact: general → networking.http

Comment 10

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking

Comment 11

12 years ago
(In reply to comment #7)
> reproducable on public site:
> http://www.dexonline.com/servlet/ActionServlet?pid=singlemappingresults&mq=Y&primaryBusinessRecordID=kct2ren4cnvoqmiqolcmenjgo&primaryHeadingID=394&primaryProductID=1012&last10Saved=true&resultForm=BASIC
> 
> I'm using
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
> 
> The file shows up as a download and if I down load it I notice the content
> encoding is gzip ... is this the same bug?

WFM on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060624 Minefield/3.0a1 ID:2006062413

Comment 12

12 years ago
Marking WFM based on comment #11
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.