search bar: bugs in text fields with highlighted search results

RESOLVED DUPLICATE of bug 259986

Status

()

RESOLVED DUPLICATE of bug 259986
14 years ago
14 years ago

People

(Reporter: norbert.notz, Assigned: bugzilla)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

search bar:

1. after changing search string, highlighting of edit fields is not updated

2. it is impossible to move the cursor through highlighted (yellow) part of edit
fields 

Reproducible: Always
Steps to Reproduce:
In Firefox 1.0 ...

1. open (for example) http://www.google.de/
2. enter (for example) "firefox browser" and confirm to search
3. press CTRL+f
4. enter "firefox browser" into the search bar
5. enable "Highlight"
6. delete the " browser" in the search bar, so that there only is "firefox"

Now the word "browser" is kept higlighted in the search fields (while in the
page content correctly only "firefox" is higlighted).

- try to edit the higlighted part of the edit field. it is impossible to set the
cursor into the yellow part!


(if the whole text is yellow it is difficult to get the cursor right beside the
text. If you select all via the context menu and then press arrow-right the
cursor is right beside the text.)


Expected Results:  
1. highlighting of edit fields should be updated correctly

2. it should be possible to move the cursor through higlighted parts of edit fields
(Reporter)

Updated

14 years ago
Summary: bug in text fields with highlighted search results → bugs in text fields with highlighted search results
(Reporter)

Updated

14 years ago
Summary: bugs in text fields with highlighted search results → search bar: bugs in text fields with highlighted search results
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
Bug 240432 is about the implementation of the highlight-feature and comment #7
(http://bugzilla.mozilla.org/show_bug.cgi?id=240432#c7) is about the described
problem with text field/area.
So this bug ist probably a dublicate of Bug 240432

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 259986 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.