Hiding and unhiding row malforms table and expands it.

VERIFIED INVALID

Status

()

Core
JavaScript Engine
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Baha Karahan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

<html>
	<head>
		<SCRIPT type="text/javascript">
function ObjectAutoHide(strObjId)
{
     var obj= document.getElementById( strObjId);
     if ( obj.style.display == "none" ) {
          obj.style.display= "inline";
     }
     else {
          obj.style.display= "none";
     }
}
		</SCRIPT>
	</head>
<body>
	<table border="1">
		<tr id="row0" name="row0">
			<td>
			<input type="button" value="BUG: Click multiple times"
onclick="ObjectAutoHide('row1')"/>
			</td>
			<td>&nbsp;</td>
		</tr>
		<tr id="row1" name="row1">
			<td>Details:</td>
			<td>Click the above button<br/>
				watch this row become mal-formed<br/>
				watch the table grow
			</td>
		</tr>

	</table>
</bodY>
</html>

Reproducible: Always
Steps to Reproduce:
Look into details, have html code their for my next contract.  Click and unclick
the button to see the issue
Actual Results:  
row is disapears(this part is good).  Click unhide and what happens is that a
new now is made - the old row to apear is displayed in a row inside a new row in
the left cell.  Hide and unhide, now ther is original row, inside a row, inside
a new row.  Table grows insize.

Expected Results:  
A single row should disapear and reapear with out the table or row expanding.

Comment 1

13 years ago
Created attachment 159325 [details]
Reporter's testcase

Comment 2

13 years ago
That's because the default display of a table row is 'table-row', not inline.

Toggle between inline and '' to get a result that works cross-browser, since IE
will not understand 'table-row'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 3

13 years ago
Toggle between 'none' and '', that is.
vrfy
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> Toggle between 'none' and '', that is.
The reporter (me) just tried this, same effect occurs - firefox 0.10 and mozilla
1.7.2
You need to log in before you can comment on or make changes to this bug.