copy mail to sent folder on imap-ssl fails often if smtp is also ssl based

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: guido, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

I use a postfix based mailserver with courier imap.
I have stunnel set up with a valid ssl certificate to provide ssl for both smtp
and imap.

I use thunderbird to access my imap-ssl e-mail. Often (30%-50%) the e-mails I
send have a problem getting copied to my sent mail folder. This is only when
using thunderbird. I use outlook 2003 in the same way and that never has the
same problem.

I am not sure but the problem seems to happen more if I use both smtp and imap
over ssl then when I use only imap over ssl and use plain text smtp.

I have tested this with old versions of thunderbird as well as the new 0.8 version.

Reproducible: Sometimes
Steps to Reproduce:
1. set up an account using courier imap with stunnel for imap ssl and smtp ssl
2. configure thunderbird to use smtp over ssl with username/pw authentication
and to use IMAP over ssl
3. compose an e-mail and press send

Actual Results:  
The e-mail will be sent just fine, no problem.
Then thunderbird tries to copy this e-mail to my sent folder on IMAP. This often
fails. I get a popup that says there was a problem copying mail to sent folder
would you like to try again.

Sometimes it works when I try again, other times it fails untill I restart
thunderbird.

Expected Results:  
copied the mail to sent without any problems. outlook2003 has no problems with
this setup.

mailserver:
debian linux
courier imap 
postfix2 smtp / mta

desktop:
windows2000
thunderbird 0.7 and 0.8

Comment 1

14 years ago
I also am having this problem, using SSL to a Courier IMAP server.  SSL is done
by the server, without any need for a separate stunnel.  My smtp server uses
TLS, not SSL.  I have only noticed the issue more recently, after an update from
Thunderbird 0.7 to 0.8.

Client:
Gentoo Linux
Thunderbird 0.8

IMAP Server:
Gentoo
Courier IMAP 2.1.2

SMTP:
not my own...campus server.

-Jacob

Comment 2

14 years ago
I believe this is the same issue discussed in bug 250657. 
http://bugzilla.mozilla.org/show_bug.cgi?id=250657

Comment 3

13 years ago
I also have this problem when sending through a Courier server. Just updated to
TBird 1.0.6 on Windows XP.

Comment 4

12 years ago
I have the same problem *without* SSL, accessing a 
SmarterMail Enterprise Edition 3.2.2327 server,
from TB 1.5.0.2, on WinXP sp2.

Not reproducible, as it does not always fail.

The e-mail seems to be sent OK (not sure if the recipient always gets it).

Thunderbird tries to copy the e-mail to the sent folder on IMAP. 
This often fails silently, but not always.

[ I do *not* get a popup that says there was a problem copying mail to sent folder. (That usually happens when i try to save a draft!!) ]

Comment 5

12 years ago
Am not using tls or ssl but am still getting failure to consistently copy mail to sent folder using imap. This has been seen consistently with since T 0.8 (the first version I used with my imap provider 1and1 ) Have come to this page from five pages of folk on a forum: 

http://forums.mozillazine.org/viewtopic.php?p=2428726#2428726 

who are wondering if anything is ever going to get done on this one. Several are looking to move away from open source products as a result of this ongoing failure.

This seems to have been around for over a year.

Is anyone looking for a solution?

Comment 6

12 years ago
Am not using tls or ssl but am still getting failure to consistently copy mail to sent folder using imap. This has been seen consistently with since T 0.8 (the first version I used with my imap provider 1and1 ) Have come to this page from five pages of folk on a forum: 

http://forums.mozillazine.org/viewtopic.php?p=2428726#2428726 

who are wondering if anything is ever going to get done on this one. Several are looking to move away from open source products as a result of this ongoing failure.

This seems to have been around for over a year.

Is anyone looking for a solution?

Comment 7

12 years ago
Frank, I've actually fixed a lot of difficult problems in this area. Have you tried using TB 2.0 alpha?

Comment 8

12 years ago
Running 1.5.0.5 (and a few previous 1.5's), I have not experienced this issue.
-Jacob

Comment 9

12 years ago
Frank, do you see the same results as Jacob?

Comment 10

12 years ago
(In reply to comment #9)
> Frank, do you see the same results as Jacob?
> Following suggestion from David Bienvenu I tried alpha 2 which produced the same problem. Went back and changed cache down to 4 and made problem worse, moved up to cache 6 and after a couple of wobbles, which may have been induced by me, the result seems to be stability. On a couple of occasions the process seems to have nearly stalled but when I clicked on the sent folder to open it I found the mail safely there and the 'stuttering' dialogue box gone. Can't track exact date of cache alteration to 6 but certainly it was working on 5.9.06.  The suggestion to change server caches I held off on.
Hope this helps.
frank

Comment 11

12 years ago
(In reply to comment #4)
Replying to my own comment, to update and clarify.

I have a similar problem (but SSL is *not* involved),
accessing this type of IMAP server:
SmarterMail Enterprise Edition 3.3.2439
from TB 1.5.0.7
on WinXP sp2.

Unlike before, sent messages are now almost always copied
to the "Sent Items" folder on the server;
it failed once, a week ago; the recipient did get the message.

When I open the "Sent Items" folder, to check,
it often does not update completely on the first try;
if i wait for half a minute before trying, or
if i open some other folders first,
the content of "Sent Items" is usually refreshed fully.

I have once or twice noticed something similar happen
when opening another IMAP folder, but don't recall which one.

There is a related bug:
While writing a message i press Ctrl+S to save a draft;
a message appears, saying there was an error
copying the message to the "Sent Items" folder;
i do not want to copy to "Sent Items", so i click Cancel;
there is then another message saying that copying the draft failed.
But, the message actually *was* saved to the "Drafts" folder OK,
so there is nothing functionally wrong.
(Is the problem just a spurious error message, or did it
*really* try to copy (wrongly) to the "Sent Items" folder?)

This is a different, but related, issue:
(wish i could figure out where to report
something that's not quite a bug; please advise)
Every time i save a draft it makes a new copy,
instead of overwriting the existing one,

jh

Comment 12

12 years ago
(In reply to comment #11)
>...
> While writing a message i press Ctrl+S to save a draft;
> a message appears, saying there was an error
> copying the message to the "Sent Items" folder;
> i do not want to copy to "Sent Items", so i click Cancel;
> there is then another message saying that copying the draft failed.
> But, the message actually *was* saved to the "Drafts" folder OK,
> so there is nothing functionally wrong.
> (Is the problem just a spurious error message, or did it
> *really* try to copy (wrongly) to the "Sent Items" folder?)

if you search on the message I think you will find bugs filed on these


> This is a different, but related, issue:
> (wish i could figure out where to report
> something that's not quite a bug; please advise)
> Every time i save a draft it makes a new copy,
> instead of overwriting the existing one,

perhaps bug 11387 or bug 141209?

QA Contact: general
Reporters, does the issue still occur in the latest supported Thunderbird 2.0.0.x or trunk nightlies?
Whiteboard: CLOSEME 2008-04-30

Comment 14

10 years ago
Gary Kwong wrote:
Reporters, does the issue still occur in the latest supported Thunderbird
2.0.0.x or trunk nightlies?

My answer: No.
Thanks to all who fixed it :)

-jh

Comment 15

10 years ago
likewise to jh, have had no problems since last few builds - likewise happy and thankful for folks who got this sorted
Resolving WFM based on comments #14 and #15.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME 2008-04-30
You need to log in before you can comment on or make changes to this bug.