Last Comment Bug 26022 - XHTML 1.0 document with text/html media-type is treated as HTML 4.0 document.
: XHTML 1.0 document with text/html media-type is treated as HTML 4.0 document.
Status: VERIFIED DUPLICATE of bug 48351
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows 95
: P3 normal (vote)
: M18
Assigned To: Judson Valeski
: Chris Petersen
: Jet Villegas (:jet)
Mentors:
http://www.horobi.com/moztest/#2
: 44819 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-31 23:58 PST by Ryosuke_Nanba
Modified: 2000-09-27 16:38 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ryosuke_Nanba 2000-01-31 23:58:42 PST
Non-html tags in XHTML 1.0 document are ignored when the document lebeled with 
the Internet Mediatype "text/html".
To be browsed old web browser, some XTHML documents are labeled with 
"text/html", not labeled whith "text/xml". In new XHTML comformant browser 
renders such documents as XHTML documents.
Comment 1 troy 2000-02-01 08:22:53 PST
Nisheeth, we never claimed we would deal with XHTML, but it's XML related so 
re-assigning to you
Comment 2 Nisheeth Ranjan 2000-02-08 14:32:26 PST
Moving these XHTML bugs to M17...
Comment 3 Nisheeth Ranjan 2000-04-04 14:33:09 PDT
Moving bugs out by one milestone...
Comment 4 Nisheeth Ranjan 2000-04-12 22:39:02 PDT
Harish, another DTD selection problem for you.  I think we should implement the 
heuristic that if an HTML file contains and XML PI right up top, we should use 
the XML DTD to parse it.

CCing Rick Gessner for his opinion.
Comment 5 harishd 2000-04-14 14:50:29 PDT
The parser is been given a wrong mime type...   Reassinging to valeski.
Comment 6 harishd 2000-07-25 17:14:01 PDT
*** Bug 44819 has been marked as a duplicate of this bug. ***
Comment 7 Hixie (not reading bugmail) 2000-08-10 12:23:34 PDT
Duping to a later bug because the later bug has a more complete set of 
testcases attached and highlights problems with the approaches mentioned above.

*** This bug has been marked as a duplicate of 48351 ***
Comment 8 Joseph Elwell 2000-09-27 16:38:12 PDT
xhtml run through the html parser. marking verified duplicate.

Note You need to log in before you can comment on or make changes to this bug.