If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mailto: link improperly launches Outlook Express instead of Mozilla Mail.

RESOLVED DUPLICATE of bug 202497

Status

()

Firefox
Shell Integration
--
major
RESOLVED DUPLICATE of bug 202497
13 years ago
13 years ago

People

(Reporter: Bryce Mozilla Nesbitt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

This report is made to confirm and reopen the issue mentioned in Bug #245539 .

On Windows XP and Windows 2000, clicking on a mailto: link brings up outlook
express, which then says "would you like to make outlook express your default
email client".

This may be Microsoft's bug, but it is Firefox's problem.  It is a major
handicap to bring up the wrong email client.  I propose that Firefox hack in a fix.

Tested on:
Browser: Firefox 1.0PR1
OS: Windows 2000 Professional, fully patched
Default E-Mail in Control Panel->Internet Options: Mozilla Mail

From "Start->Run..." entering "mailto:" also brings up Outlook Express.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
(Reporter)

Updated

13 years ago
Summary: Firefox launches wrong email client with mailto: link, need workaround for Microsoft bug → Firefox email mailto: link improperly launches Outlook Express. Need workaround for Microsoft bug in XP/2000.
We don't need to hack in a fix, you just need to make sure the correct mail
client is set in the OS.  We just pass the mailto: URL to windows, and that's
all we should do.  We are not going to try to do some sort of hacky solution,
when most users are unaffected by this.  I do not have this problem on two XP
and one 2000 machine, so it isn't some generic bug.

Filing another bug because the first one was marked INVALID is pretty much
ignoring what was said in the first bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

13 years ago
You have no idea if "most" users are unaffected by this.

The correct email client clearly IS set in the OS.

Additional data:
   Tools->Read Mail loads the proper email client.
   Tools->New Message loads the wrong one.
   Clicking on a mailto: lionk loads the wrong client.

So what's different about two neigboring menu items (in Firefox tools menu)
launch email clients?

IE, Opera and Mozilla get it right in all cases (on the SAME machine).
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 3

13 years ago
This is a frequently reported problem:

Bug #245539 INVA mailto: link opens Outlook Express not my email client
Bug #254927 INVA Default mail client not honored when clicking a mailto: l...
Bug #260265 WONT Firefox email mailto: link improperly launches Outlook Ex...
Bug #241381 INVA e-mail client does not open when clicking a mailto: link ...
Bug #258753 INVA Firebird doesn't open default mail application when click...

This bug seriously undermines my enjoyment of Firefox.  That's why I'm reporting it.

At the very least if you don't want to see new bug reports, give us victims of
the problem a open bug report to find & vote for.
We're not in the business of leaving bugs open that we have no intention of
"fixing."  Application protocol handlers work fine, there's no bug in XP/2000,
your mail app is busted.  That's the simple truth.

Despite Bugzilla not being intended for "support" I'm just going to explain this
here, so that future bug reports can at least look here for the truth.

If you want to vote for a bug to get fixed, its Bug 202497, which is about
fixing Mozilla Mail to do what the OS API _requires_. 
http://texturizer.net/firefox/faq.html#email has the manual workaround for the
MozMail bug noted above.  

Also, please note that Thunderbird, Eudora, OE, Outlook, and other email apps
all seem to use the OS standard (since at least Win98) properly.  Lotus Notes
didn't do it, when done via Internet Options, but that may be by design.

Morphing summary to what the bug really is, marking as a dupe of the real bug.

*** This bug has been marked as a duplicate of 202497 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Summary: Firefox email mailto: link improperly launches Outlook Express. Need workaround for Microsoft bug in XP/2000. → mailto: link improperly launches Outlook Express instead of Mozilla Mail.
You need to log in before you can comment on or make changes to this bug.