Polish the preferences pane on Mac OS X

RESOLVED INVALID

Status

()

Firefox
Preferences
--
trivial
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Dave Chand, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

When you open firefox preferences in firefox and go to privacy the window cuts
off some text inside the pane. I have attached a rather large jpeg 321KB showing
the problem

Reproducible: Always
Steps to Reproduce:
1.On OS X open firefox preferences and go to privacy
2.
3.

Actual Results:  
See jpeg
(Reporter)

Comment 1

14 years ago
Created attachment 159339 [details]
JPEG Showing the problem
(Reporter)

Updated

14 years ago
Attachment #159339 - Attachment is obsolete: true
(Reporter)

Comment 2

14 years ago
Created attachment 159340 [details]
JPEG showing the problem circled in red

Comment 3

14 years ago
Like the following comments, if userChrome.css is customized, this problem will
not be generated.
http://bugzilla.mozilla.org/show_bug.cgi?id=233781#c4

Mac OS X 10.3.5
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7.3) Gecko/20040918
Firefox/0.10

Updated

14 years ago
Depends on: 233781
(Reporter)

Comment 4

14 years ago
I put * { font-family: 'Lucida Grande'; } in my user chrome. The problem did not
go away.

Comment 5

14 years ago
I have added the following entries.
* { font-family: "Lucida Grande", sans-serif !important; }
(Reporter)

Comment 6

14 years ago
Modifying the userChrome.css as you suggested does work. But it should be more
refined and work out of the box. 

Updated

14 years ago
Assignee: bugs → firefox
Component: OS Integration → Preferences
QA Contact: firefox.os-integration → mconnor

Comment 7

14 years ago
Created attachment 159933 [details]
The example of a problem at the time of installing a language pack

When a language pack is installed, a display is confused further.
It is a problem that a display is confused only by changing language.
*** Bug 261476 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

14 years ago
version 1.0RC2 20041103 : this problem is visible only in :
 - Privacy/Cookies
 - Privacy/Download Manager History
 - Privacy/Cache
but the Cookies one is the most problematic because the 
right buttons completely disappear. Some <br> in the text
may shorter the width of the sheet and voila.

Comment 10

13 years ago
This has nothing to do with bug 233781.
Why the userChrome.css in comment 5 works is that it increases
the width of the pane.
Removing dependency.
No longer depends on: 233781

Comment 11

13 years ago
not valid any more with new prefs - I don't see any problems now
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 12

13 years ago
I was referring to the February 2005 new prefs landing on the trunk
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.