Text in External Protocol Request warning window overflows

RESOLVED FIXED

Status

Core Graveyard
File Handling
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Mennonite, Unassigned)

Tracking

Bug Flags:
blocking-aviary1.0 -
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I clicked a link for an "external protocol" on a web page.  A warning box popped
up, with the title External Protocol Request.  The third paragraph of warning
text overflows the right hand side of the non-resizable dialog box.  An
indeterminate amount of text (at least a few words) is unreadable.

Reproducible: Always
Steps to Reproduce:
1.Click on a link for an external protocol
2.try to read all of the warning text
3.

Actual Results:  
Couldn't read all text

Expected Results:  
Word-wrap the text; make the dialog box larger and resizable.
(Reporter)

Comment 1

14 years ago
Created attachment 159357 [details]
Screen Capture
Assignee: nobody → jag
Component: Layout: Fonts and Text → XP Apps
QA Contact: core.layout.fonts-and-text → pawyskoczka
Confirming. Probably want to fix this for final, long urls are probably common
enough.

Need to clip the url at the window border... it's pushing the box boundary out
of the dialog and then the second para is wrapping on the redefined box.
Unfortunately this is the shared ConfirmEx() dialog so short of defining a
custom dialog (l10n impact at a late date) all we have control over is character
length with no access to the ultimate display length.
Assignee: jag → dveditz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?
Why not fix ConfirmEx()?

Comment 4

14 years ago
almost out of time for this.  renominate if a patch appears
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Created attachment 161544 [details]
Another screen capture

This is another screen capture with a little different word wrapping.
I just encountered the same error in Firefox 0.10.1 except for the fact that the
word wrapping is worse (it cuts off in the middle of the sentence).

I'm not a JavaScript coder, but I would think something as simple as fixing the
word wrapping wouldn't be very difficult. This is a pretty major text problem as
it is displayed everytime a link to another program is used.
(In reply to comment #6)
er, I just noticed that this is handled under C++ and not JavaScript... sorry :)
Product: Core → Mozilla Application Suite

Comment 8

14 years ago
I just found this bug in Firefox 1.0 (Win XP) today when clicking on an itms
(iTunes Music Store) protocol. I haven't included a screen capture, as it will
be redundant - it's very similar to the one Reed Loden has provided in <a
href="https://bugzilla.mozilla.org/show_bug.cgi?id=260292#c5" title="Comment
#5">comment #5</a> above.

Comment 9

14 years ago
*** Bug 273651 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
If bug #273651 is a dupe of this one, then shouldn't this one be changed to include Mac OS X?

Comment 11

13 years ago
Created attachment 189550 [details]
Buttons rendered outside of the dialog

On the trunk builds the buttons aren't rendered inside of the Dialog making
this dialog unusable.

Comment 12

13 years ago
Same in OS X 10.4.2, when trying to access the iTunes Music Store. -> All/All

Why is the product set to Mozilla Application Suite when all the comments are
about Firefox?
OS: Windows XP → All
Hardware: PC → All

Updated

13 years ago
Component: XP Apps → MailNews: Search
Product: Mozilla Application Suite → Core

Comment 13

13 years ago
*** Bug 268796 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
*** Bug 283462 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Component: MailNews: Search → XP Apps
Product: Core → Mozilla Application Suite

Updated

13 years ago
Component: XP Apps → Address Book

Updated

13 years ago
Component: Address Book → XP Apps

Updated

13 years ago
Component: XP Apps → File Handling
Product: Mozilla Application Suite → Core
This is fixed in 1.8 already btw.

Updated

13 years ago
Blocks: 316184
*** Bug 316184 has been marked as a duplicate of this bug. ***
*** Bug 316184 has been marked as a duplicate of this bug. ***
(In reply to comment #15)
> This is fixed in 1.8 already btw.

Not exactly. gavin (and I'm inclined to agree after seeing what happens on Mac) sees this "new way" as still a bug. He states that "it should do something smarter than presenting a huge dialog."

The new way of showing the box is still better than the old way on Windows as the new box will go to the screen width instead of just a static length. The buttons can still be seen and used.

Macs don't seem to do the same as Windows and the message box continues on past the screen length (see screenshot in bug 316184 comment 1). This causes problems as the buttons can not be seen as they are also off-screen.

Mossop thinks that "cutting the url short but providing a tooltip to it would probably be sensible."

Would it be possible to word-wrap the URL to some length and then allow tooltip if longer or such (or a form of that)?

Can anybody check this on Linux to see what it does?
Flags: blocking1.8.1?
Requested blocking1.8.1 since this is extremely annoying and some form of this bug has been around for a while (i.e., it would be nice if this could be fixed for a later 1.5 release).

Updated

13 years ago
No longer blocks: 316184

Comment 20

12 years ago
Created attachment 216882 [details]
Screencap from MacOSX 10.3/FF 1.5.0.1

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Go to http://www.coverville.com/archives/podcast/index.html and select a link from one of the cover songs.

Comment 21

12 years ago
Not going to block 1.8.1 for this, but we'll happily consider a baked-on-trunk patch.
Flags: blocking1.8.1? → blocking1.8.1-

Comment 22

12 years ago
(In reply to comment #21)
> Not going to block 1.8.1 for this, but we'll happily consider a baked-on-trunk
> patch.
> 

This is becoming more and more of a problem.  It seems that this recently also became a problem on Windows version of Firefox.  Here are comments from https://bugzilla.mozilla.org/show_bug.cgi?id=316184 which indicate this bug is a problem for iTunes U users.


This bug is reproducible for a lot of users of the iTunes U service.  I have
been able to reproduce it using Firefox 1.5.0.4 and Firefox 1.5.0.6.

Build identifier:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4)
Gecko/20060508 Firefox/1.5.0.4

This bug is also effected by the preferences network.protocol-handler.external
and network.protocol-handler.warn-external .  If a user has already clicked on
an itms:// or itmss:// URL, seen this panel, checked the checkbox for "Remember
my choice for all links of this type." then they will no longer be presented
this panel.
Assignee: dveditz → nobody
This dialog has gone away.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.