crash if site trys to "change status bar txt" and "disable or replace context me..." and these are diabled in javascript options

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: csling1, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

At http://www.hoovers.com/free there is a company search in the upper left. 
Leave all the settings default on the page and type a company name in.  Firefox
(PR 1.0/.10; Mac OSX) will crach if the "change status bar text" and "disable or
replace context me..." options are diabled under the javascript settings under
preferences.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox (PR 1.0/.10; on Mac OSX 10.3.5)
2. Open preferences->web features->enable javascript-> advanced
3. uncheck "change status bar text"
4. uncheck "disable or replace context me..."
5. surf to http://www.hoovers.com/free
6. in dialog box under "Search for business information" enter company name,
i.e. Pepsi, Google, etc.
7. click search

Actual Results:  
Firefox crashes and wants to send feedback.

Expected Results:  
Should not crash, should open sanctioned pop-up and on background page, surf on.

I have had several issues since switching to .10 but believe that most of them
result from this.  I usually leave most of my javascript options off.

Comment 1

14 years ago
Works for me (OSX 10.3, FF 1.0PR)
(Reporter)

Comment 2

14 years ago
I tried this problem a dozen times before submitting it to make sure I wasn't
imagining it (crashed under the right conditions, didn't under the wrong ones).
 I turned all the options on and off in the javascript menu in turn and finally
found this combination that it consistently worked with, submitted the ticket.  

Now when I go back and try it I can't reproduce it!  I am terribly sorry for the
inconvenience, I obviously did not make up my crashes but I can no longer
reproduce the problem (did not upgrade, did not even restart).  Again please
excuse the inconvenience.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.