Invision Power Board: <!--QuoteBegin- tag end is missed

RESOLVED DUPLICATE of bug 259766

Status

Tech Evangelism Graveyard
Other
RESOLVED DUPLICATE of bug 259766
14 years ago
3 years ago

People

(Reporter: Yedyge, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

another url
http://forums.airbase.ru/index.php?showtopic=27899
sorry, forum is in russian language.
but the rendering is obviously wrong.

Reproducible: Always
Steps to Reproduce:
1.go to url named
2.look at page rendered
Actual Results:  
page composition looks like a broken table

Expected Results:  
page composition is a straight table
(Reporter)

Comment 1

14 years ago
probably it is caused by nick starting with "-" (minus)

Comment 2

14 years ago
I see this in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3)
Gecko/20040817 as well.

--> Browser
Assignee: bugs → nobody
Component: Web Site → Layout
Product: Firefox → Browser
QA Contact: core.layout
Version: unspecified → Trunk

Comment 3

14 years ago
I don't see this. The page seems to render just fine for me. 

Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Comment 4

14 years ago
I get the exact same unbroken rendering in IE6 and 20040918 trunk, PC/WinXP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
the website contains invalid comments, so that sourcecode is involuntarily
skipped as comment.
Search in the source for <!-- THE POST 389634 --> and read text afterwards:

<td id='QUOTE'><!--QuoteEBegin--> <!--QuoteBegin--exec-+22.04.2004
19:51:48--><table border='0' align='center' width='95%' cellpadding='3'
cellspacing='1'><tr><td><b>QUOTE</b> 

The invalid comment:
<!--QuoteBegin--exec-+22.04.2004 19:51:48-->

use of multiple dashes inside comments is dangerous, if you don´t want to read a
complicated spec what is allowed and what is an error, don´t use them.

http://htmlhelp.com/reference/wilbur/misc/comment.html
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

14 years ago
Dupe of Bug 259766 	missing posts and content broken web page
using the same invalid comments.

*** This bug has been marked as a duplicate of 259766 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Component: Layout → Browser-General
Resolution: --- → DUPLICATE

Comment 7

14 years ago
hhschwab@gmail.com: if this isn't the same site or the same product then it
should have its own bug.
Component: Browser-General → Other
Product: Browser → Tech Evangelism
Version: Trunk → unspecified

Comment 8

14 years ago
(In reply to comment #7)
> hhschwab@gmail.com: if this isn't the same site or the same product then it
> should have its own bug.

It is not the same site, but the same product, and same buggy comment style:
here: 
Powered by Invision Power Board(Trial) v2.0.0 PF 4 © 2004  IPS, Inc.
<!--QuoteBegin--exec-+22.04.2004 19:51:48-->

there: 
Powered by Invision Power Board(U) v1.2 © 2003  IPS, Inc.
<!--QuoteBegin--FaygoFreakGC+Jul 26 2003, 03:33 PM-->
(Assignee)

Updated

3 years ago
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.