Closed Bug 260392 Opened 17 years ago Closed 5 years ago

sportsline.com - Live scoring script loop triggers the "run slowly" alert

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: Friendster, Unassigned)

References

()

Details

(Keywords: qawanted, top500, Whiteboard: [country-us])

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

Live scoring on cbs sportsline http://tbffl7.football.sportsline.com dows not work properly. An error 
keeps poping up saying "A script on 
this page is causing Mozilla to run slowly if it continues to run your computer may computer may 
become unresponsive. Do you want to abort the script?"

This works fine on Win2k/IE and works ok (albeit a bit slowly) on Safari 10.3.5.

This site requires a login, which I will provide via email to QA.

Reproducible: Always
Steps to Reproduce:
1.go to the above URL while football is going on (Sunday/Monday).
2. On the left hand side of the page look for the box labeled At a glance. Click on any link labeled GM
Actual Results:  
The page does not update properly and the error dialog above is displyed

Expected Results:  
Live scoring should work
Not more xrep badness, I hope!  Or perhaps JS1.2 abusage counting on == not
being ===?

/be
Assignee: general → nobody
Component: JavaScript Engine → English US
Product: Browser → Tech Evangelism
Version: Trunk → unspecified
Keywords: qawanted
i have the login info and am looking into it now
I can not reproduce this using winxpsp2 in FF 0.10 from 9/17 nor in seamonkey
trunk or 1.7 from about the same time. Note that FF does show a constant 8-9%
load on a dual xeon 3G machine while seamonkey shows no load except when the
page is being updated.  Even changing the UA on a seamonkey build to match FF on
Win/Mac does not reproduce the dialog and does not show the 8-9% CPU load. The
app does use copious js1.2 scripts but I didn't see that causing problems in
this case but the scripts are hard to step through in venkman and I have crashed
doing so at least twice. There is copious browser and plugin detection in the
scripts as well.

Dave, the page loads fine for me and updates properly with no js errors in the
console.  Does it happen when the page first loads after you click "gm" or does
it happen when the page updates scores every minute? What plugins do you have
installed ? What kind of machine do you have ? slow|fast?

Does anyone have a Mac to use to debug this?
(In reply to comment #3)
> I can not reproduce this using winxpsp2 in FF 0.10 from 9/17 nor in seamonkey
> trunk or 1.7 from about the same time. Note that FF does show a constant 8-9%
> load on a dual xeon 3G machine while seamonkey shows no load except when the
> page is being updated.  Even changing the UA on a seamonkey build to match FF on
> Win/Mac does not reproduce the dialog and does not show the 8-9% CPU load. The
> app does use copious js1.2 scripts but I didn't see that causing problems in
> this case but the scripts are hard to step through in venkman and I have crashed
> doing so at least twice. There is copious browser and plugin detection in the
> scripts as well.
> 
> Dave, the page loads fine for me and updates properly with no js errors in the
> console.  Does it happen when the page first loads after you click "gm" or does
> it happen when the page updates scores every minute? What plugins do you have
> installed ? What kind of machine do you have ? slow|fast?
> 
> Does anyone have a Mac to use to debug this?

Hi Bob,

The machine I'm using a a 1.2ghz G4, not too slow but not a speed demon either. This happens after it 
refreshes after a while (come to think of it, sorry I should have included that eariler). I will try to 
reproduce on a Win machine at home.
letting the page load for > 1/2 hour does not show the "run slowly" dialog in
either Mozilla 1.7.3 for Firefox 1.0PR on winxpsp2. If this exists, it is not a
Windows issue.
*** Bug 260403 has been marked as a duplicate of this bug. ***
This could be either evangelism or a bug in the run slowly alert, depending on
your point of view.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Depends on: 78089
Ever confirmed: true
OS: MacOS X → All
QA Contact: pschwartau → english-us
Hardware: Macintosh → All
Summary: Live scoring at cbs sportsline does not work properly. → sportsline.com - Live scoring script loop triggers the "run slowly" alert
The branch callback measures time now, so it shouldn't need to be called a
certain number of times -- just often enough and early enough.

/be
Argh, that comment was meant for a different bug.  But perhaps it sheds light
here, too.

/be
Apparently I submitted what amounts to the exact same report that has now been 
labeled a duplicate.  During week #1 of the NFL season I experienced this 
problem continuously.  I would go to the live scoring "GameCenter" page for my 
FantasyFootball league and after a few minutes the whole system would slow 
down and I would get that time out error.  Now I haven't experienced it 
since.  I think it may be also related to a server load issue.  For some 
reason when it did happen IE6 worked perfectly when the script on FireFox kept 
timing out.  I will keep trying to replicate the problem...

I was just using a plain jane version of FireFox with nothing special.

The script is supposed to automatically update the scoreboard as the players 
on your Fantasy Football team score points.  It sounds logical to me that the 
script queries a server periodically and the time outs might be ocurring here?

Please let me know if there is anything else I can do to help.
Keywords: top500
I experience this as well... with vanilla Firefox 1.5.0.7... to reproduce the bug go to http://www.sportsline.com/collegefootball/scoreboard on any given Saturday (well... any time a Live game is going on) and open up a "GameCenter" for any game that is progress.  Let it sit there for a little while... it will happen to you.

This is _HIGHLY_ annoying for me.  I usually track about 6 or 7 different games at a time on multiple laptops while watching multiple TVs (yes, I know I'm a football freak) and keeping up with click "Continue" for all the different games I'm tracking is getting ridiculous.

I would be happy with just a "Continue Forver" or "Do Not Ask Again" option when the first one comes up....

Derek
I have the feeling that the Web site has changed since this bug report. The GameCenter doesn't exist anymore, there is something like Gametracker which opens a different page.
Assignee: english-us → nobody
Component: English US → Desktop
Whiteboard: [country-us]
Let's close it as INVALID.
The page redirects now to http://www.cbssports.com/fantasy/football/games/prize-leagues
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.