hangs on all downloads (example - downloading java runtime environment from plugindoc/mosdev.org/linux.htm; further example: right click on any image, any web page and click on 'save image')




Downloads API
14 years ago
8 years ago


(Reporter: ernesto gomez, Assigned: Ben Goodger (use ben at mozilla dot org for email))


Firefox Tracking Flags

(Not tracked)





14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

CPU usage goes to 99% for firefox-bin. Sometimes download starts. On a very few
occasions, download completes. Once (out of perhaps 20 tries) firefox recovered
and ran after hanging for about a minute, on a 21K image. I am not sure if
Firefox would have eventually completed downloading a larger file, since in most
cases I killed the process after several minutes of apparent inactivity.

Reproducible: Always
Steps to Reproduce:
1. Start firefox
2. Goto any website
3. Attempt any download, either by selecting a download option or by right-click

Actual Results:  
Firefox hangs, consumes up to 99% of CPU resources. Resource usage goes down
sometimes to perhaps 70%, but no effect on user interface, browser is still not
responding. If I switch to a different workspace, when I switch back to Firefox
it displays the background image in its window.

Expected Results:  
Started download and returned.

 Bug occurs with standard theme, as well as with Pinball and Sphere Gnome
themes, have not tested other themes. I am running Red Hat 9.0, using the
WindowMaker .80.1 window manager. My video card is an ATI Rage Mobility 7500.
2GHz Mobile Intel Pentium 4 - M. Firebird .7 works fine on this system.

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b2) Gecko/20050220 Firefox/1.0+

I cannot reproduce this bug, Reporter, can you still see this with a nightly
build and a clean profile? If not, please close this bug.

Comment 2

13 years ago
Reporter has not responded in more than 3 weeks, and according to comments, this
is unable to be reproduced (not to mention it is an old bug from almost a year
ago).  Resolving Invalid. 


If you can reproduce this in the latest milestone or a recent (no more than 3
days old) nightly build, then re-open.
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.