If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find Toolbar sometimes captures form field input.

RESOLVED DUPLICATE of bug 258285

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 258285
13 years ago
9 years ago

People

(Reporter: Chris Granade, Assigned: Blake Ross)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Using the bookmarklet attached to post to del.icio.us, sometimes the Find
Toolbar will "capture" input to the form fields. That is, when typing into the
description field on the resultant page, sometimes, the find toolbar will appear
and start searching for the string that the user attempted to enter, as opposed
to appending the input to the form field's value.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Use bookmarklet.
2. Attempt to add text to tags field.
Actual Results:  
String entered into Tags field spawns search for string.

Expected Results:  
Allowed input to the form field.

Comment 1

13 years ago
I noticed the bug too. For example in http://www.mtv.it/music/index.asp if you
try to write something in the green text box (handled by flash) you'll get the
find bar working.

Comment 2

13 years ago
I see this very frequently, but still intermittently, on many form (not using
the bookmarklet). It seems like it only happens when I have more than one tab
open (but still is a problem if I close all other tabs). Hopefully I can
investigate this further and come up with a reliable reproduction procedure.

This should block 1.0. I think the severity should be raised to major, since
it's a real pain when you are trying to type in a form field and the focus is
repeatedly stolen.
Flags: blocking-aviary1.0?
I see this behavior sometimes (no steps to repro' at the moment)
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 260566 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
if someone comes with a good test case and/or patch renoiminate
Flags: blocking-aviary1.0? → blocking-aviary1.0-
wouldn't this be a dup of bug 258285?

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041010
Firefox/0.10.1

I can confirm this also, it happens to me more frequently since 2-3 weeks, with
'standard' text areas. Unfortunately, I'm unable to reproduce it, it seems to
happen randomly as I really don't know what triggers it. This bug is really
annoying when I want to post on a forum as the only solution I know is to
restart Firefox.
(In reply to comment #6)
> wouldn't this be a dup of bug 258285?

Yes, thanks.

*** This bug has been marked as a duplicate of 258285 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.