Cannot Run Filters On Local Folders

RESOLVED DUPLICATE of bug 177093

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 177093
13 years ago
13 years ago

People

(Reporter: Chris Ellison, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

There is no way to run filters on the local folders (those folders that are not
associated with any email account).  I suspect that this problem similarly
affects those who use the new global inbox feature.

I know that the idea is that the filters are ran when the mail is first
received...and thus, is delivered to the proper place.  However, I can think of
many scenarios in which the "filter as mail arrives" concept is not an adequate
solution.

Scenario 1:  You have imported 1000 Outlook messages that were in the same
folder.  Now, these messages are in a special account that has no identities
associated with it.  Indeed, Thunderbird will admit this when you check the
properties of your local folders. "The following is a special account. There are
no identities associated with it."  The task, get these messages sorted.  How
would I do that...well, I would run a filter on the 'Inbox' within the 'Local
Folders'.  The only problem is that one cannot do that.

Scenario 2:  You have many accounts configured to use the global inbox.  At the
time, you do not believe that there is any benefit of having filters---so you
don't create any.  After 1 year, your inbox is FULL of unsorted messages and you
say to yourself, "Maybe I should start organizing these messages." So the first
thing you do is make sure that all future messages are sorted.  The second thing
one would do is sort all the messages that you previously received.  Now, how
would you do that?  Well, you would want to create a filter and run it on the
local folders...but you cannot do that.

I have that I have stated the problem clearly.  One solution, it seems, would be
to allow the user to run ANY filter from ANY account on ANY folder.  When you
click Tools -> Run Filters On This Folder, a window would pop up prompting the
user to select an existing filter from some account OR it would allow the user
to specify a new filter that could be saved, if the user so pleased.

Another solution might be to allow the user to specify filters that are
applicable to EVERY folder. Obviously, one would have to work out some sort of
conflict checking so that conflicting filters are dealt with in a proper fashion
(some sort of ordering or superceding of the filters might work).

A final solution, might be to allow the user to specify filters for the Local
Folders only.  This would prevent conflicts---by its design since it keeps the
accounts separate---and it would allow the user to sort messages that were not
previously filtered.

I am marking this bug as 'major' since 'filtering' does not work, especially for
those using a global inbox trying to filter messages that were not filtered when
first received.  Though, I would understand if someone interpreted this 'bug' as
a 'feature request' or just as a 'normal' bug.

Chris

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
The problem with large-scoped bugs is it's not easy to decide which of the 
several possibilities to dupe them to.

Case 1 is bug 177093.
Case 2 is bug 257979.
See also bug 129883.

*** This bug has been marked as a duplicate of 177093 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.