absolute link translation

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Kotlyarov Roman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When i save some page (local) to another location on my disk, links to graphics on this page translates absolutely. For example, file was saved in my document and settings folder; previously link look like this:
<A href="amd/athlon64-3800plus-s939/a64-3800+front-large.jpg"><IMG height=282 src="iXBT  Процессор AMD Athlon 64 3800+ под Socket 939_files\a64-3800+front.jpg" width=290 border=0></A>

Then when Firefox save this file to d:\ link look like this:
<a href="file:///C:/Documents%20and%20Settings/Roman/My%20Documents/_iXBT/amd/athlon64-3800plus-s939/a64-3800+front-large.jpg"><img src="iXBT%20%20%CF%F0%EE%F6%E5%F1%F1%EE%F0%20AMD%20Athlon%2064%203800+%20%EF%EE%E4%20Socket%20939_files/iXBT%252520%252520%252520AMD%252520Athlon%25252064%2525203800%252520%252520S.jpg" border="0" height="282" width="290"></a>

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

14 years ago
Assignee: aaronleventhal → bugs
Component: Accessibility → File Handling
QA Contact: bugzilla → bmo

Comment 1

14 years ago
This is by design. When Firefox saves a page, it translates the links into
absolute links because it is assumed that those links will let you view the page
when you return to it later. If it had saved with relative links (not even
possible in your case, since you saved on a different drive), you'd just have a
bunch of broken links and images.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.