column picker & column change size when clicked

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: dmitry rusanov, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.5) Gecko/20031006 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.5) Gecko/20031006 Firebird/0.7

column picker change size when clicked

treecol:hover:active,
treecolpicker:hover:active {
  border-top: 2px solid;
  border-right: 1px solid;
  border-bottom: 1px solid;
  border-left: 2px solid;
  -moz-border-top-colors: ThreeDShadow -moz-Dialog;
  -moz-border-right-colors: ThreeDShadow;
  -moz-border-bottom-colors: ThreeDShadow;
  -moz-border-left-colors: ThreeDShadow -moz-Dialog;
}

this style resize border column pick with rigth and bottom on 1px. 

if I add this is style , then size column and column picker not changed
treecol:hover:active,
treecolpicker:hover:active>image {
	padding-top : 1px; 
	padding-left	: 1px;
}


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
rather 

treecol:hover:active>image,
treecol:hover:active>label,
treecolpicker:hover:active>image {
	padding-top		: 1px; 
	padding-left	: 1px;
}

Comment 2

13 years ago
*** Bug 260463 has been marked as a duplicate of this bug. ***
Over to XPFE, but is this a problem in Suite, or just in firefox?
Assignee: general → guifeatures
Component: DOM → XP Apps: GUI Features
QA Contact: ian

Comment 4

13 years ago
Over to relevant tree and firefox guys.
Component: XP Apps: GUI Features → XP Toolkit/Widgets: Trees
(Reporter)

Comment 5

13 years ago
I download last version FireFox and I see you fixed this is inaccuracy.

treecol:hover:active,
treecolpicker:hover:active {
  border-top: 2px solid;
  border-right: 1px solid;
  border-bottom: 1px solid;
  border-left: 2px solid;
  -moz-border-top-colors: ThreeDShadow -moz-Dialog;
  -moz-border-right-colors: ThreeDShadow;
  -moz-border-bottom-colors: ThreeDShadow;
  -moz-border-left-colors: ThreeDShadow -moz-Dialog;
  padding: 1px 4px 0px 5px;
}
Ok, marking so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.