If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Choose Helper Application doesn't allow selecting application

RESOLVED DUPLICATE of bug 225574

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 225574
13 years ago
13 years ago

People

(Reporter: reto bachmann-gmuer, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

The dialog to choose a helper application doesn't allow selection of most
applications. For the content-type application/rdf+nt (innoficial) it allows
selecting:
1. any document (which makes no sense)
2. the application "SVGViewCarbon" (which cannot handle the media-type)

It doesn't allow the selection of TextEdit of jedit which I'd like to open. 

Reproducible: Always
Steps to Reproduce:
1. go to a page that serves some unusal media-type
2. press the choose button
3. try to open with TextEdit

Actual Results:  
You cannot choose the application

Expected Results:  
If firefox instists on being smart, it should at least give an option "only
suggested applications" which could be disabled in order to be able to select
any application.

Workaround: save file and open with whatever you like.

*** This bug has been marked as a duplicate of 225574 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.