"Select element by click" doesn't work with documents that contain frames

RESOLVED DUPLICATE of bug 240892

Status

Other Applications
DOM Inspector
RESOLVED DUPLICATE of bug 240892
13 years ago
10 years ago

People

(Reporter: Dan Berindei, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I browse a page with frames in Firefox and I invoke the DOM Inspector, I
can't select any element in a frame by clicking on it.

Reproducible: Always
Steps to Reproduce:
1. Open a page containing frames in Firefox.
2. Invoke the DOM Inspector from Tools|DOM Inspector.
3. Click on the "Find a node to inspect by clicking on it" button.


Actual Results:  
Nothing happens, no node is selected in the DOM Inspector and the button is
still pressed.

Expected Results:  
It should have selected the clicked node in the document tree and it should have
depressed the button.

The feature works ok if I inspect the same document in the DOM Inspector window
(using the menu File|Inspect a URL...).

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 240892 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: "Select element by click" doesn't work with documents that contain frames → "Select element by click" doesn't work with documents that contain frames
Product: Core → Other Applications
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.