Unable to unselect/clear category selection once one is chosen

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: victor.engmark, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When creating a new event, the "Categories" field is per default empty. Two
problems where apparent with the current solution:
1. There is no "Empty" selection, i.e. after selecting a category you cannot
remove it.
2. There seems to be no way to specify several categories for an event,
something which is very useful e.g. if you have a hierarchy of descriptions
(birthdays are a subset of celebrations are a subset of personal events).

Reproducible: Always
Steps to Reproduce:
*** Bug 260514 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Reporter:
   The issue about multiple category selection seems to be being addressed in
bug 122646.  Your report is very similar to bug 259487, which was also marked as
a duplicate of that bug.  Please look over those reports and if you agree that
yours is a duplicate, resolve it as such.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)

This bug report is a "superset" of bug 259487. Neither of the reports discussed
the possibility of deselecting the category.

Please set as confirmed.

Comment 4

14 years ago
Confirming for ability to unselect category only.  Summary changed to reflect this.

Hardware: All
Component: Front-End
OS: All
Blocks: bug 122646 - Categories Tracking Bug
Status: NEW

Note (in reply to comment #3): In general, "superset" bugs are discouraged. 
It's better to only report one issue per bug.
Blocks: 122646
Status: UNCONFIRMED → NEW
Component: General → Sunbird and Calendar-Extension Front End
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Unable to select zero / many categories for event → Unable to unselect/clear category selection once one is chosen
QA Contact: gurganbl → sunbird

Updated

13 years ago
Depends on: 298102

Comment 5

13 years ago
The issue about unselecting categories was fixed by the unification of the event dialogs (bug 296893).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.