Recurrence should update end date

RESOLVED INVALID

Status

Calendar
General
--
enhancement
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Victor Engmark, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When specifying that an event is recurring e.g. forever, the end date should not
stay unchanged. A "forever event" should have the end date greyed out, while an
"until event" should have its end date set to its "until" date. The end date for
a  numerically repeated event should be computed and inserted into the end date
field.

Generally, you need to specify whether the end date or the recurrence
information has precedence. See also bug #248630
(http://bugzilla.mozilla.org/show_bug.cgi?id=248630)

Reproducible: Always
Steps to Reproduce:

Comment 1

13 years ago
The start and end dates set the start and end of each occurrence.
Each recurrence has the same duration as the first occurrence.  So it would not
make sense to set the end date to the end of the recurrences.  That would
produce a single long event.

Example recurring event: training camp every year from 1 Aug to 15 Aug for 5
years.  Setting the end date to 15 Aug 2009 would make for one 5-year event, not
5 events of 2-weeks each.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> The start and end dates set the start and end of each occurrence.
> Each recurrence has the same duration as the first occurrence.  So it would not
> make sense to set the end date to the end of the recurrences.  That would
> produce a single long event.

IMHO:
This makes sense, but it should be made explicit. The way it's done in Outlook
is better (the start + end date and recurrence are mutually exclusive), but it
should accomodate for several independent recurrences (e.g. thursdays 12-14 and
mondays 15-17).

Comment 3

13 years ago
Reporter:
    In light of the discussion with gekacheka, can you clarify exactly what this
bug report is now asking for? Recurrence is now in its own tab in the New Event
dialog, which, in my opinion, makes it separate enough.  Right now though, I
can't figure out under what conditions this bug should stay open/close.
(Reporter)

Comment 4

13 years ago
IIRC, the problem was that there was still an "End date" field after specifying
an endless repetition, which doesn't make sense.
The end date of the event is the end date of the first occurence, just like the
start date is the start of the first occurence. The end date of the recurrence
is greyed out (at least in trunk builds)
So depending on what the 'end date' in the summary means, this is either
worksforme or invalid.

Updated

12 years ago
QA Contact: gurganbl → general

Comment 6

12 years ago
Reporter seems to be confusing "end date" (of first occurrence) on the main tab
with the "until date" (of recurrences) on the recurrence tab.  The until date is
disabled if there is no recurrence.

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.