Scrollbar in main window never disappears in month / multiweek view

RESOLVED FIXED

Status

Calendar
Sunbird Only
--
trivial
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: Victor Engmark, Assigned: Michiel van Leeuwen (email: mvl+moz@))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When using the month or multiweek views, the main window contents always resize
to be a bit larger than the available space.

Reproducible: Always
Steps to Reproduce:
1. Open Sunbird
2. Click the "Multiweek" or "Month view" buttons
(3. Resize window)
Actual Results:  
The contents of the main calendar window resizes to a slightly bigger size than
the window size, no matter how big the application window is.

Expected Results:  
The contents should fit exactly in the window.
Confirmed on trunk; 20041010.  Note that this only happens with some months (in
month view) -- January, July, and October have no scrollbar.  The main content
window should probably never have a scrollbar in this view.  An annoying side
effect is that the "next month" arrow button ends up shifting by the scrollbar's
width when you move through months when you hit a month with no scrollbar,
making it difficult to quickly flip through a few months.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

13 years ago
This is due to the use of collapsed instead of hidden.
Assignee: mostafah → mvl
(Assignee)

Comment 3

13 years ago
Created attachment 165897 [details] [diff] [review]
use hidden
(Assignee)

Updated

13 years ago
Attachment #165897 - Flags: first-review?(mostafah)

Updated

13 years ago
Attachment #165897 - Flags: first-review?(mostafah) → first-review+
(Assignee)

Comment 4

13 years ago
patch checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

13 years ago
*** Bug 274921 has been marked as a duplicate of this bug. ***
Oh, it's fixed already.  Sorry for my additional bug, but the latest build dated
back to November.
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.