system-wide install ruined the migration process

RESOLVED INVALID

Status

()

Firefox
Installer
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Gary Lawrence Murphy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

On the bidding of the 1-million downloads ;) I grabbed the installer and, as I
usual do, ran it as root using sudo.  all goes well until we get to the debug
reporter and "migrate old settings"

debug gets permanently broken, repeating the process under a user account
doesn't fix it, and the migrated components aren't -- bookmarks and passwords
are migrated for the base user (the user who ran the sudo, not for root) but
other components and plugins had to be migrated by hand.

Reproducible: Always
Steps to Reproduce:
1. run installer under sudo
2. choose /opt/firefox-1.0 as the base directory
3. select to migrate old components.



Expected Results:  
the installer should detect being run by root and default or offer to make a
system-wide installation.

the installer should check for common locations of mozilla plugins
(/usr/lib/mozilla/plugins) and either symlink those to the install target.

still haven't figured out how to get the crash report module working.
(Reporter)

Updated

13 years ago
Summary: system-wide install ruined the process → system-wide install ruined the migration process
Version: unspecified → 1.0 Branch

Comment 1

13 years ago
using sudo with any part of Mozilla is a bad idea.  sudo doesn't change the
environment, so Mozilla uses the user's dir for the profile and accesses (and
writes to) it as root.

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Version: 1.0 Branch → unspecified
since the installer is no longer included in Linux Firefox Builds/Releases i mark this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.