Cannot switch back to Emacs keybindings!!!

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
15 years ago
a month ago

People

(Reporter: garym, Assigned: bugzilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

This is driving me nuts -- Firefox 1.0 no longer obeys the emacs keybindings
inside forms and the location bar; all keybindings are now presumably windows,
and old habits are very hard to break.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
the option to enable controls such as Ctrl-D and Ctrl-K within edit boxes should
be selectable under an advanced UI option.
(Reporter)

Updated

15 years ago
Version: unspecified → 1.0 Branch
use the GNOME keybinding prefs to set this.  That's what the current behaviour
is, on GTK2 builds.

And if you don't use GNOME, there's always google to find out how to set them
without GNOME (since of course, Firefox on Linux is currently a GNOME-oriented
app, that's the WM we hook into).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
*** Bug 261465 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
*** Bug 261465 has been marked as a duplicate of this bug. ***
*** Bug 265071 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 265402 has been marked as a duplicate of this bug. ***
*** Bug 271521 has been marked as a duplicate of this bug. ***
*** Bug 260188 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 273021 has been marked as a duplicate of this bug. ***
*** Bug 275445 has been marked as a duplicate of this bug. ***
I must admit to being very unhappy with the resolution to this bug:
  1) The behavior of the browser has changed from something lots of people have
been used to for a hell of a long time. (Ctrl-U to clear a box is ancient
behaviour on many platforms).

  2) The mechanisms to allow users to edit this are arcane and unreliable as
described at 'http://kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29' it
involves a number of 'change that, but on this version that didn't work, or
instead you might have to change that'.

  3) I'm a KDE user who uses Mozilla - please don't break things for those of us
who don't primarily use Gnome (I use various gnome apps - e.g. gnumeric/gnucash
etc) - please don't assume all your users use it under Gnome.

Changes to behaviour like this should allow users to revert to what they are
used to without having to do stuff that arcane.
Dave
*** Bug 282084 has been marked as a duplicate of this bug. ***
Component: Preferences → Keyboard: Navigation
Product: Firefox → Core
Version: 1.0 Branch → Trunk

Comment 13

14 years ago
guys and gals, this really sucks big time. I just accidentally closed a tab with
a comment to this bug when I wanted to delete the word to the left of the cursor
with ^W.

this bug (and it's a bug in my book) is not Firefox- or Linux- specific, I
*suffer* from it using Mozilla on FreeBSD without Gnome.

I really hope the "blocking" mean what I think they mean, and the resolution
INVALID doesn't mean what I think it means. Or are you telling all the unix
users to sod off? please, fix this before releasing 1.8.

in the mean time, what's the procedure to fix this regression in Mozilla
system-wide?

btw, I don't see this gratuitous change either in
http://www.mozilla.org/releases/mozilla1.8a6/README.html or
http://www.mozilla.org/releases/mozilla1.8a6/known-issues.html#browser
*** Bug 283034 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
Reverting res/builtin/platformHTMLBindings.xml to a version with Emacs support
is a start.

How do we get emacs shortcuts to apply to the File dialog boxes?
*** Bug 284120 has been marked as a duplicate of this bug. ***
*** Bug 311881 has been marked as a duplicate of this bug. ***
*** Bug 312530 has been marked as a duplicate of this bug. ***

Comment 19

14 years ago
This bug is not resolved!

comment #1:  what do you do on a mac without gnome?

comment #4:  the link from comment number 4 is broken.

Comment 21

14 years ago
(In reply to comment #20)
> http://kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29
> 
> (specifically
> http://kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29#Any_OS.2C_without_GTK )

These instructions ask you to modify a file called "toolkit.jar".  No such file
exists on my computer anywhere. 
(In reply to comment #21)
> These instructions ask you to modify a file called "toolkit.jar".  No such file
> exists on my computer anywhere. 

Quoting from the page:
"On OS X, you will need to open show the contents of the application package by
choosing "Show package contents" from the contextual menu of the application in
the Finder. Then you have to browse to Contents/MacOS/ within the package."

Please keep any further support requests out of bugzilla, that's what IRC or the
forums are for. See http://www.mozilla.org/support/ .
*** Bug 359767 has been marked as a duplicate of this bug. ***
Component: Keyboard: Navigation → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.