Unable to install themes from disk and from webserver running on localhost




Add-ons Manager
14 years ago
10 years ago


(Reporter: Jaap A. Haitsma, Assigned: Ben Goodger (use ben at mozilla dot org for email))


Firefox Tracking Flags

(Not tracked)




14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

If I go to http://texturizer.net/firefox/themes/ and use the theme installer
overthere to install a theme which is stored on my harddrive. It fails silently.
The javascript console contains an error message that a script cannot access
local files. 

Then I tried installing it of an webserver installed on localhost. It then seems
to install but is immediately removed from the theme list. When I copied the
files to my public webserver it all of a sudden worked

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 263787 ***
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
This is not the same bug as bug 263787
Resolution: DUPLICATE → ---

Comment 3

14 years ago
What is the theme you tried to install?
How did you try to install it from local webserver (installtrigger, simply going
to the its URL or by using texturizer's tool?)
How did you try to install from a public webserver?

Is it reproducable, can you still reproduce it with a recent build?

this is related to bug 258811.

Comment 4

14 years ago
OK with Fx 1.0 it now works on a local webserver. :-)

Using the http://texturizer.net/firefox/themes/index.html still does not work
I get the following javascript error

Error: Access to
'file:////home/haitsma/Programming/gnomefx/src/GNOME-Fx-blue.jar' from script denied
Source File: http://texturizer.net/firefox/javascript/themeSetup.js
Line: 32

Maybe a safety measure that got taken???

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 14 years ago13 years ago
Resolution: --- → EXPIRED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.