Setup.exe extracts 100%, but never installs or gives any options

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Matt Kellerman, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705)
Build Identifier: 

Using XP SP2, I try installing FX version .9.3 and 1.0PR. Both exe's extract, 
a window opens for a quarter of a second and I can't see what the window says. 
It doesn't install, or give any other options or indications.

Reproducible: Always
Steps to Reproduce:
1.Double click the exe.
2.
3.

Actual Results:  
Goes through the extraction process, opens a window and closes very quickly.

Expected Results:  
Given the installation options.

Comment 1

14 years ago
This also happens in Windows 2000.  The only fix I found around it, was to
download and install Mozilla as a browser, and then re-download (to a new
folder) Firefox, and install it.  At least with Mozilla, it tells you that
before you can install it, you must close all of your Netscape windows.  If this
is the problem with installing Firefox, it should tell you the same thing.

Comment 2

14 years ago
I assumed there was a problem with the downloaded file so bought the CD.

It arrived today (08.01.05) and I have the same problem.

Immediately after the progess bar reaches 100% a small error pane comes up with 
something about "integrity" and "archive". It disappears too quickly to read any 
more and returns to the opening menu.

I get exactly the same thing with the Thunderbird CD.

I have had Netscape 4 and 6 on my system in the past (Windows 98) and am running 
Opera 7.54 and Netscape 3.

Comment 3

14 years ago
I have tried installing the CD on my next-door neighbours computer, and it works 
OK.

He has Windows 98SE, but no other browsers or e-mail than Explorer and OE.

The window mentioned says "Verifying Integrity of Archives, please wait"

So presumably the problem is on my machine. The next question therfore is What 
archives? and how do I put them straight?

Comment 4

14 years ago
Is this bug possibly related to that described in 234275?

Comment 5

13 years ago
(In reply to comment #2)

> Immediately after the progess bar reaches 100% a small error pane comes up with 
> something about "integrity" and "archive". It disappears too quickly to read any 
> more and returns to the opening menu.

I installed Win98 in a VMware virtual machine, and applied SP1.  With no other
software installed, Firefox 1.0.2 installer fails consistently at exactly this
point.  The message is "Verifying integrity of archives, please wait..."

Not sure whether this is relevant, but the .exe is on a share served by Samba.

Comment 6

13 years ago
FYI, 1.0.2 shows the same behaviour for en-US and en-GB variants.  1.0.1 and 1.0
(en-GB) do too.  But 0.9.3 installs just fine.
Having installed 0.9.3, and asking it to "check now" for software updates, it
fails to find any.  Trying to install 1.0.2 manually still fails.

Comment 7

13 years ago
This also happens on win98, with 1.0.6

Since firefox (next to opera) is the only browser capable of doing anything on
such a setup it was the first thing i tried to install.

IE4 which comes as the default browser doesn't work anymore, can't download
drivers, or run windows update due to javascript errors.

I used Opera to download nvidia drivers, but the problem persists.
Current situation:
win98, no updates.
Nvidia detonator drivers, for geforce2
Opera 8 installed.

Comment 8

13 years ago
I have since installed this OK on two other computers, one Windows 98, the other 
Windows XP. The only difference is they have never had Netscape installed. 
Sometime I'll strip my computer down and try again but not right away because 
I'm extremely happy with Opera 8.

Comment 9

13 years ago
I get the same on NT/4.0 and Firefox 1.0.6

I started by uninstalling Internet Explorer.   That uninstalled more than I
expected, including Outlook Express (good riddence), DirectShow?, NetMeeting,
the Internet connection wizard?, and many others.

What happens:
  - 100% Extracting
  - Initializing Setup, Please wait
  - Verifying Archive Integrity of Archives, Please Wait
  - at this point, the installer dies quietly.   Task Manager shows
    the program is no longer running.

Opera 8.02 installed ok.   Firefox still wouldn't install after opera installed.



Comment 10

13 years ago
Have you at any time had Netscape on this machine?

If I rebuild I don't simply deinstall I have four drives on my system, so I 
reformat drive C: and overwrite it with graphic files (booting off the diskette) 
so there's no chance of anything left. The trouble is that, for this, I might 
have to do the same for Drive E: and reinstall all my application programmes 
which is just too much hassle.

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer

Comment 11

13 years ago
This Problem can be fixed by installing MSIE 6 SP 1 on Windows 98. I kid you not. After doing that, I was able to start setup for Firefox.

I found this out when I - confronted with the problem described here - snatched Firefox portable and tried to run it. This brought a popup that said something wrong with a "OLEAUT32.DLL" (the version was too old as I later found out). Obviously Installing a complete IE6Sp1 is overkill, but I have no idea how else I could have gotten a relatively current OLEAUT32.DLL
Version: unspecified → 1.5.0.x Branch
Closing WFM per comment 11. If others experience this problem, head over to http://support.microsoft.com/kb/214845/en-us to update your OLEAUT32.DLL file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.