Mouse wheel button will not scroll frame if top of frame is not visible

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Brian Pape, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

If the top of a frame is not visible in the current page, the mouse scroll wheel
will not scroll the page.  Worse, when scrolling down through a frame, and the
end of the frame is reached, Firefox will scroll the entire page, pushing the
top of the frame out of view, and you cannot then scroll back UP the frame
without scrolling the main window to bring the top of the frame back into view.



Reproducible: Always
Steps to Reproduce:
1. Load above example bugzilla page
2. place mouse cursor over the frame listing the bugs
3. use mouse scroll wheel and scroll to the bottom of the frame, and keep scrolling
4. The entire page will then scroll, and the top of the frame will scroll off
the screen

Actual Results:  
5. The mouse scroll button no longer will scroll the frame even when it is
placed over the frame.  The only way to get the frame to respond to mouse scroll
events is to scroll the main page itself until the top of the frame is again
visible.

Expected Results:  
Anytime the mouse cursor is over a frame, the frame itself should accept the
events and scroll itself.  (i.e. Mozilla 1.7.3 does this properly)

This makes using the mouse scroll button almost unusable.

Comment 1

13 years ago
Firefox does this but only on certain websites, such as TVGuides listing page

Comment 2

13 years ago
On a related note, if you hold your mouse over an inner window and scroll down
with the mouse button, then it will stop scrolling once it reaches the end of
the inner window.  Generally when this happens, the outer window should scroll
down if it has the chance.  Moreover, this only seems to be an issue with
scrolling down, if you are scrolling up it does the correct thing, and will
scroll the outer window if the inner window can not scroll up any farther.  
Assignee: bross2 → nobody
The steps in comment 0 work for me. Resolving as WFM. If you can reproduce using Firefox 2.0.0.3 or later and using a new profile, please reopen.

http://kb.mozillazine.org/Profile_Manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.