Cannot set location of disk cache

RESOLVED DUPLICATE of bug 251016

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 251016
14 years ago
13 years ago

People

(Reporter: Lorraine, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.23; Mac_PowerPC)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

Firefox for Mac OS X has never had an option to set the location of the cache folder. I 
have a separate scratch volume which I use for browser caches. I would like to be able to 
create a folder for Firefox on that volume and set a preference within Firefox to have it 
use that location. This would protect my data volume for all the read/write hits that occur 
while surfing.

Reproducible: Always
Steps to Reproduce:
1. check preferences
2. there is an option to set the size of the cache but not the location.
3. cache folder is written into user's home folder.



Expected Results:  
Need a preference to allow setting the location of the cache folder onto any mounted 
volume, like in Mozilla.

Comment 1

14 years ago
it should actaully be ~/Library/Caches, which can be a symbolic link to another
disk (not an alias)

see bug 216204
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> it should actaully be ~/Library/Caches, which can be a symbolic link to another
> disk (not an alias)
> 
> see bug 216204

On my powerbook running OS 10.2.8, the cache is actually located in my home
folder in the following path:

~/Library/Application Support/Firefox/Profiles/default.3bk/Cache

I may try the symlink work-around, but it would be best of Firefox had a
preference to set the location of the cache folder, just like Mozilla has.

Thank you.

Comment 3

14 years ago
Normally you can set the location of the cache, but because of bug 217146, this
fails on Mac.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Normally you can set the location of the cache, but because of bug 217146,
this fails on Mac.

Firefox for Macintosh has no preference for setting the location of the cache,
which would be located in Firefox > Preferences > Privacy > Cache. The Windows
version is mising this feature also, which would be located in Tools > Options >
Privacy > Cache.

This is why I'm requesting a preference for this. Mozilla has such a preference,
but not Firefox. It would be good if such a preference could be added, and if
any underlying issue that might prevent the addition of this preference could be
resolved.

Thank you.

Comment 5

14 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > Normally you can set the location of the cache, but because of bug 217146,
> this fails on Mac.
> 
> Firefox for Macintosh has no preference for setting the location of the cache,
> which would be located in Firefox > Preferences > Privacy > Cache. The Windows
> version is mising this feature also, which would be located in Tools > Options

There's no UI to change the path, see
http://texturizer.net/firefox/tips.html#oth_cache for a workaround. Except for
the mac (bug 217146).

Requests for a UI like this have been denied so far. Mostly to make the UI
simple (that's the whole point of Firefox), but also to avoid problems when
people set an incorrect path (slow, over the network, unavailable after you log
out, ...), or when it has other side-effects (like what happens when the
RAM-drive is smaller than your cache).

Updated

13 years ago
Depends on: 217146

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 251016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Preferences
OS: MacOS X → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE

Updated

13 years ago
OS: All → MacOS X
Hardware: All → Macintosh
You need to log in before you can comment on or make changes to this bug.