Getting mail freeze on bad header mail

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Stephane Flament, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Getting mail freeze when I receive mail with incomplete header such as :

Return-Path: <Willis@targetedmarketing.biz>
Received: from adsl-69-224-38-71.dsl.irvnca.pacbell.net (69.224.38.71) by
mail.libertysurf.net (6.5.036)
id 414D0D4E001F7163 for sflament@libertysurf.fr; Mon, 20 Sep 2004 02:28:57 +0200
Sender: Willis@targetedmarketing.biz (derived from envelope by
postmaster@libertysurf.fr)
Date: Mon, 20 Sep 2004 02:28:57 +0200 (added by postmaster@libertysurf.fr)
Message-ID: <M3[3


OR


Return-Path: <Hunter@targetedmarketing.biz>
Received: from host59-51.pool8253.interbusiness.it (82.53.51.59) by
mail.libertysurf.net (6.5.036)
        id 414938F20000C00B; Thu, 16 Sep 2004 10:49:50 +0200
Sender: Hunter@targetedmarketing.biz (derived from envelope by
postmaster@libertysurf.fr)
Date: Thu, 16 Sep 2004 10:49:50 +0200 (added by postmaster@libertysurf.fr)
Message-ID: <f2563a8N[2

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




The work around is to connect to my web mail, to delete the wrong mail and to
launch againt the "get mail" on thunderbird", then, remaining mails are uploaded
correctly.

Comment 1

13 years ago
pop3 or imap? Are there more headers or a msg body after the message-id, or is
that the end of the message?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
I'm having an apparently identical problem. Thunderbird stalls retrieving email
((50% CPU usage on a dual-processor system) on Windows XP. Can read and compose,
but sending and retrieving fail, and the animation in the corner never stops
cycling. Exiting the GUI still leaves a "thunderbird.exe" process running (still
eating CPU) that needs to be killed manually with the Task Manager.

 Is there any way to get a debug console or other way of seeing what Thunderbird
is trying to do at this time?

 Unfortunately, while the ISP's (twmi.rr.com) webmail interface can delete the
email, whatever's broken about it also prevents it from viewing or reliably
forwarding the broken message. The mail server is Pop3. It's my wife's account
that is getting the spam. If possible, I will try to download it using fetchmail
on Linux.

 For now, I have attempted to reconstruct it below:

Return-path:  	<heine_rosena@btopenworld.com>
Received  	from ms-mta-02 (ms-mta-02 [10.24.14.216]) by
ms-mss-04.columbus.rr.com (iPlanet Messaging Server 5.2 HotFix 1.21 (built Sep 8
2003)) with ESMTP id <0I4T00CI735J6V@ms-mss-04.columbus.rr.com> for
domenica@twmi.rr.com; Wed, 29 Sep 2004 10:05:43 -0400 (EDT)
Received:  	from nymx02.mgw.rr.com (nymx02.mgw.rr.com [24.92.226.159]) by
ms-mta-02.columbus.rr.com (iPlanet Messaging Server 5.2 HotFix 1.21 (built Sep 8
2003)) with ESMTP id <0I4T00CZP35HX9@ms-mta-02.columbus.rr.com> for
domenica@twmi.rr.com (ORCPT domenica@twmi.rr.com); Wed, 29 Sep 2004 10:05:43
-0400 (EDT)
Received:  	from da-160-206.ala.tularosa.net (da-160-206.ala.tularosa.net
[66.18.160.206]) by nymx02.mgw.rr.com (8.12.10/8.12.8) with SMTP id
i8TE52P5027865; Wed, 29 Sep 2004 10:05:33 -0400 (EDT)
Received:  	from stab.mail.chello.nl by 24.92.226.159; Wed, 29 Sep 2004 21:04:22
+0600
Date:  	Wed, 29 Sep 2004 10:05:22 -0500
From:  	jamee stacy <stacy_jamee@chello.nl>
Subject:  	You do not need to suffer the pain. A
To:  	domenica@TWMI.RR.COM
Reply-to:  	jamee_stacy@chello.nl
Message-id:  	<895557117359.x1WLZZR40406@mentor.mail.chello.nl>
MIME-version:  	1.0
X-Mailer:  	Ximian Evolution 1.2.2 (1.2.2-5)
Content-type:  	multipart/mixed
Content-transfer-encoding:  	7bit
X-Priority:  	3
X-Virus-Scanned:  	Symantec AntiVirus Scan Engine
Original-recipient:  	rfc822;domenica@twmi.rr.com

 "http: //www.w3.org/TR/html4/loose.dtd">

<HTML>
<HEAD>
<TITLE>PARMACIA.BIZ</TITLE>

</HEAD>
<BODY>
<p>
Hi Domenica,
<p>
Tips to Help in Managing Chronic Pain. Stay positive: Think that you will
control the pain
. Keep your spirits up, this will help to maintain your ability to overcome and
manage pai
n.
<p>
Take charge of your medical conditions now. Order online. Live a healthier and
happier lif
e - all from the comfort of your home!
<p>
Highest quality drugs we offer: = v1aGr@ ) So.m.a ~ Pnter:m:in - V|cod|:n <
_X_ANAx > A.t|
v@n
<p>
Plus: X'3nica|, Amb'i3n, S.0naTa, Fl3xer'il, Ce|3:brex, Fi0ric:3t, Tram@`do|,
U|t'r@m, L3v
|t'ra, Pr0p3c.ia, Acyc|0:vir, P.r0z@c, P@x.il, Busp`@r, A:d|pex, I0n:am|n, M:3ridia
<p>
Most trusted name brands.  <a href="http://www.PARMACIA.BIZ">www.PARMACIA.BIZ</a>.
<p>
Best regards,
<p>
jamee stacy
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<p>
<img src="http://www.PARMACIA.BIZ/o.php?e=domenica@twmi.rr.com&d=PARMACIA.BIZ"
width="1" h
eight="1" alt="PARMACIA.BIZ">
</BODY>
</HTML>

Comment 3

13 years ago
you can set up pop3 protocol logging:

http://www.mozilla.org/quality/mailnews.html#pop

What build are you running? On the trunk, we've checked in a pop3 timeout that
will abort connections when the server stops sending data after XX seconds which
will help a little, but you'll still get stuck on that message, unfortunately.
You can turn on header only download (pop3 server settings) and try to delete
the message that way, or as you say, use webmail. I'm not sure what's going on
with the server that the bad messages cause the pop3 protocol handler to spin,
if that's what's happening - cc'ing ch.ey, he'll remember, I'm sure...

Comment 4

13 years ago
While Stephanes mails really miss some lines like From: (instead we've Sender:)
or To:, Rays mail looks complete (and besides it states it's multipart/mixed but
isn't, I can't see anything wrong). 
So if really bad headers make us freeze, Rays problem might be another one.

But it's more likely something in the mails makes the servers freeze and we wait
and wait for them to continue.

As David wrote, the timeout should prevend Mozilla/TB from doing that for than
45 seconds (by default).
The remaining problem is that the mail is still on the server.


It would be interesting what you, Stephane, mean with "Getting mail freeze".
Freeze like nothing repaints in TB window, no reaction to clicks or "only" what
Ray experiences?

Comment 5

13 years ago
This bug seems very similar indeed to
https://bugzilla.mozilla.org/show_bug.cgi?id=228649

Have a read and try out the suggestions; turning off Junk Mail Controls,
filtering and anti-virus and see.
QA Contact: general
(Reporter)

Comment 6

11 years ago
version 2.0.0.4 (20070604)
I do not notice freeze now (since a long time now)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.