Software update can be cancelled

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
critical
RESOLVED INVALID
13 years ago
6 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Darin Fisher)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [asaP1])

(Reporter)

Description

13 years ago
STEPS TO REPRODUCE
1. Upgrade firefox using the Check Now option.
2. While the progress bar spins, hit the [X] button on the wizard.

EXPECTED RESULTS
There should be no [X] button, since Cancel is disabled.

ACTUAL RESULTS
The download is aborted, leaving the system in God-knows what state.

Comment 1

13 years ago
Doesn't "system in God-knows what state" warrant a higher than "normal" severitiy ?

( I confrim the bug, on FF 0.10 , windows server 2003 )

Comment 2

13 years ago
A day later I rerun FF, click the red update icon in the upper right corner and
FF craches ( first the "Checking for updates" dialog appears, then after a
second or two the feedback dialog appears and all other FF windows disappear ).
Severity: normal → major
OS: Windows 2000 → All

Comment 3

13 years ago
I think we have this on file elsewhere. I'll try to find the dupe.
Severity: major → critical
Flags: blocking-aviary1.1+
Whiteboard: [asaP1]
(In reply to comment #3)
> I think we have this on file elsewhere. I'll try to find the dupe.

Do you mean bug 284314?

Comment 5

13 years ago
*** Bug 284314 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
This may be no longer applicable. Need to retest with new update goods. Darin,
can you tell us if this is all changed?
Assignee: bugs → darin
(Assignee)

Comment 7

13 years ago
I'm designing the new update system to not support cancelation mid-stream, so I
think we can mark this as fixed by the new update system.

Marking INVALID since this bug is no longer applicable.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 290390
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.