[FIX][trunk] No cursor to indicate image resizing

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Bill Mason, Assigned: mats)

Tracking

(Blocks: 1 bug, {pp, regression})

Trunk
x86
Windows XP
pp, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040920 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040920 Firefox/0.9.1+

The magnifying glass cursor that normally appears over an image that has been
resized to fit the browser window (via the pref) no longer appears.

The image still toggles between full/shrunk size when clicked.  There's just no
cursor change.

Worked in the 2004091908 trunk build.
Broken in the 2004092008 trunk build.

Reproducible: Always
Steps to Reproduce:
1. Position mouse cursor over a 'shrunk to fit browser window' image.
2.
3.

Actual Results:  
No mouse cursor change occurs.

Expected Results:  
A magnifying glass mouse cursor should indicate that resizing has occurred.

This works in the 20040920 Aviary branch, and the 20040920 Seamonkey trunk. 
Only the FF trunk is affected.
(Reporter)

Updated

14 years ago
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 1

14 years ago
Mats, I'm wondering if your fix for bug 259639 ("Remove some cursors") caused
this regression.
(Assignee)

Comment 2

14 years ago
I wonder too :-)  I get the same results as you - I can reproduce with FF but
not Moz. Here's the strange bit: the bug does NOT occur with a current
CVS "debug" build of Firefox on the same host (this is on Windows XP).
Then I tried an "opt" build - still no problem. Finally, I tried
with "--enable-static --disable-shared" (which is how the FF nightlies
are built) and then the bug occurs.

Furthermore, it's not just the zoom cursors, try attachment 154812 [details]
(Testcase from bug 163174) - most of the cursors on the lower part of the page
does not work (again everything works fine in the non-static builds.)

Looks like a build config/compiler/linker problem?
Keywords: pp

Comment 3

14 years ago
I added these cursors way back and the change hasn't been reverted nor
overwritten.  They're only defined if MOZ_STATIC_BUILD is defined.

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=splash.rc&branch=&root=/cvsroot&subdir=mozilla/browser/app&command=DIFF_FRAMESET&rev1=1.5&rev2=1.6
(Assignee)

Updated

14 years ago
Assignee: firefox → mats.palmgren
Summary: [trunk] No cursor to indicate image resizing → [FIX][trunk] No cursor to indicate image resizing
(Assignee)

Comment 4

14 years ago
Created attachment 166058 [details] [diff] [review]
Patch rev. 1

Thanks Dean, that was the problem.

I found that this file has been copied to two other places as well:
calendar/sunbird/app/splash.rc
xulrunner/app/splash.rc

I haven't tested those two changes though.
(and in the case of calendar I think the ..\\..\\ is not enough,
it probably should be ..\\..\\..\\ but I don't know so I'm leaving
it as is)

I have tested this patch on a static trunk build of Firefox on
Windows XP and it works as expected.
(Assignee)

Updated

14 years ago
Attachment #166058 - Flags: superreview?(firefox)
Attachment #166058 - Flags: review?(dean_tessman)

Comment 5

14 years ago
Comment on attachment 166058 [details] [diff] [review]
Patch rev. 1

Ahhh... those defines changed.	r=me, but what about mail/app/splash.rc?
Attachment #166058 - Flags: review?(dean_tessman) → review+
(Assignee)

Comment 6

14 years ago
Created attachment 166061 [details] [diff] [review]
Patch rev. 2

Fixed mail/app/splash.rc too...
Do we need to have these values in xpfe/bootstrap/splash.rc too?
(it doesn't have any cursors at the moment)
Attachment #166058 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #166058 - Flags: superreview?(firefox)
(Assignee)

Updated

14 years ago
Attachment #166061 - Flags: superreview?(firefox)
Attachment #166061 - Flags: review?(dean_tessman)

Comment 7

14 years ago
It all looks good to me.  r=me if that stands for reviews in windows-specific
code in sunbird and mail.
*** Bug 271309 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Attachment #166061 - Flags: superreview?(firefox) → superreview?(dbaron)
Comment on attachment 166061 [details] [diff] [review]
Patch rev. 2

There should really be a better way to do this.  It seems like you could at
least get the constants with an #include, judging from widget.rc.  Could you
get the whole thing from an #include, or does that not work?
Attachment #166061 - Flags: superreview?(dbaron) → superreview+
(Assignee)

Updated

14 years ago
Blocks: 271910
(Assignee)

Comment 10

14 years ago
I checked in attachment 166061 [details] [diff] [review] (2004-11-26 11:49 PDT) to fix the regression.

I think an #include would work for the constants, but I don't know
how to fix the relative paths for the cursor files.
I have filed bug 271910 on this.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

14 years ago
V 20041127 PC/WinXP
Status: RESOLVED → VERIFIED
(Assignee)

Updated

14 years ago
Blocks: 163174

Comment 12

14 years ago
Comment on attachment 166061 [details] [diff] [review]
Patch rev. 2

setting r=me to get this out of my request queue
Attachment #166061 - Flags: review?(dean_tessman) → review+
You need to log in before you can comment on or make changes to this bug.