Javascript url images and iframe images loaded eventhough 'load images' turned off in options

RESOLVED DUPLICATE of bug 64066

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 64066
13 years ago
13 years ago

People

(Reporter: Omar Khan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; rv:1.7.3) Gecko/20040913 Firefox/0.10

In the page at
http://omar_khan.blogspot.com/2004/09/broken-in-my-opinion-i-can-see-images.html
The mozilla t shirt should not appear
and the white arrow on the black background should not appear given that
the user has disabled the loading of images through tools->options->Web Features.

Reproducible: Always
Steps to Reproduce:
1. Select Tools
2. Select Options...
3. Select Web features
4. Check off Load Images
5. Select OK
5. Visit
http://omar_khan.blogspot.com/2004/09/broken-in-my-opinion-i-can-see-images.html


Actual Results:  
See an image of a shirt and a arrow.

Expected Results:  
Hide the image of the shirt and put in place of the list item a placeholder or a
bullet like Microsoft Internet Explorer(TM).
(Reporter)

Comment 1

13 years ago
Created attachment 159605 [details]
A test case showing the images.
(Reporter)

Comment 2

13 years ago
Created attachment 161617 [details]
Testcase this time using xul namespace
(Reporter)

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.3) Gecko/20041014 Firefox/0.10.1

Ok, new version of firefox,
some how the xul and
li examples no longer work;
however, the javascript image still
displays in test case 1,
so still valid concern.
(Reporter)

Updated

13 years ago
Severity: normal → minor
(Reporter)

Comment 4

13 years ago
Simple as <iframe src='http://www.mozilla.org/images/front-store.jpg' />
Summary: Javascript url images and list-style-images loaded eventhough 'load images' turned off in options → Javascript url images and iframe images loaded eventhough 'load images' turned off in options

Comment 5

13 years ago
Well, you are using styles and javascript to load the images. It's probably just
the html tag IMG SRC that's disabled by "load images". You can disable JavScript
too, of course, but I'm not sure if I'd want this bug fixed, because the time it
would take for FF to check every possible way of loading an image and blocking
it out would probably take up more time than simply loading the occasional
image... unless you use a 14.4 modem!! (-:รพ

I was able to reproduce it, though.

Mozilla/5.0 (Windows; U; Win 9x 4.90; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Comment 6

13 years ago
Well, I'm glad someone else was bugged enough by this to turn it in since I've
been annoyed by this behavior for some time now. Haven't spent the time to
figure out why or how it's doing it, but my example will be
<http://my.monster.com/>. Disabling the loading of images AND disabling
javascript seems to STILL result in those damn images getting loaded. Not a
critical problem but rather annoying since I go to Monster just about every day....

BTW Firefox PR on Linux (Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1)
(Reporter)

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 64066 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.