If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RSS feeds with Hebrew titles get doubled (twice)after re-start

RESOLVED FIXED

Status

MailNews Core
Feed Reader
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Shoshannah Forbes, Assigned: Scott MacGregor)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040919 Firefox/0.10
Build Identifier: version 0.8 (20040918)

Tested with TB 0.8 on liunux gentoo and on mac OSX:
When adding feeds to "news&blogs" that contain Hebrew titles, all looks fine.
However, after application re-start, all feeds appear double: one real one, and
one "ghost" with no content.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla thunderbird
2. Add the following RSS feeds, all with the option "don't open web page use
summery" set:
http://linmagazine.co.il/node/feed
http://www.tapuz.co.il/tapuzforum/main/rss.asp?forum=170
http://www.tapuz.co.il/tapuzforum/main/rss.asp?forum=936
http://www.tapuz.co.il/tapuzforum/main/rss.asp?forum=603
http://net.nana.co.il/RssService

3. See the feeds appear in the left pane
4. re-start thunderbird 

Actual Results:  
After re-start, all feeds appear twise

Expected Results:  
They should only appear once

* Some "ghost" feeds appear in with extra junk characters in the feed name (like
feed #1 about)
* Some "ghost" feeds appear as completly junk- like feeds #2 and #3 above
* in the "manage subscrption" db, they all appear once as they should
(Reporter)

Comment 1

13 years ago
Created attachment 159622 [details]
screen shot of the messed up feeds appearing in the left pane
(Reporter)

Comment 2

13 years ago
Adding CC's
(Reporter)

Updated

13 years ago
Summary: RSS feeds with Hebrew titles get doubled after re-start → RSS feeds with Hebrew titles get doubled (twice)after re-start

Comment 3

13 years ago
Hey!
the same thing happens with thread http://www.gazeta.pl/pub/rss/wiadomosci.xml

rel/dup: bug 258465, bug 258848
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> rel/dup: bug 258465, bug 258848

just to note- they are about single articles, this is about the full feed (see
screenshot).

Updated

13 years ago
Keywords: intl

Comment 6

13 years ago
seems to resolved in 0.9 (2004-11-19). Removed all the fees and added a new one.
This time it appeared only once. I restated thunderbird, and still appears only
once.

(Assignee)

Comment 7

13 years ago
This seems to be working correctly for me using 1.0 RC1. I'm going to mark this
as fixed. I tried the first couple test feeds and they all worked ok. 
Target Milestone: --- → Thunderbird1.0
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Target Milestone: Thunderbird1.0 → ---
You need to log in before you can comment on or make changes to this bug.