When first trying to connect Firefox should attempt to connect without using the proxy

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
15 years ago
3 years ago

People

(Reporter: esarge, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I have a laptop that I use both at home and at work. At work I require a proxy,
at home I don't.
Under IE I can configure the proxy and when I start it up at home IE will
attempt to connect without using it. At work, once it detects that it needs to
use it will prompt me to log in and then use the proxy.

Firefox requires me to manually unset the proxy setting.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

14 years ago
Confirming.  Over to the networking component.
Assignee: firefox → darin
Status: UNCONFIRMED → NEW
Component: General → Networking
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → benc
Version: unspecified → Trunk

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking

Comment 3

13 years ago
(added myself to CC)

the problem is that firefox is being told to follow a set of rules that aren't appropriate
try the auto-detect option, as i think that will fit your needs better

as for trying to use a direct connection first, that's not a good idea, because same admins need to leave direct access available for a small number of non-proxy apps, but would prefer browsers to use the proxy instead of connecting directly

again, try auto-detect, that will try to use the proxy first, then try a direct connectinn (your network admin at work may need to configure a few things if he hasn't already to enable auto detection)

Comment 4

13 years ago
auto detect seens the best solution here...

one other solution is a hidden pref to a alternate proxy preference if the first isnt working

auto proxy is good for work related laptops, the hidden pref would be good for roaming home users

to keep things even simpler, this dual proxy would be set for all the session (ie: no auto-switch after one proxy start to work)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.