Closed Bug 260889 Opened 17 years ago Closed 17 years ago

100% of processor resources used, stays used

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 275783

People

(Reporter: jsteinhilper, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

I've noticed that when I have several tabs open, after a random amount of time,
and with random sites loaded, the processor usage will approach about95% and
bounce between about 95% and 100%, after a short time, it will rise to 100% and
stay there.  The pages are not reloading, no video or anything is going on,
these are just text sites.
Normally, I have to close FireFox to regain the use of my machine again.  One
time I was able to close all but one window, and I regained the processor.  I
was not able to duplicate that again.  It may be the first tab, I mean, if I
close all open tabs but the first one, I MAY regain processor, if I close all
but the second tab, I didn't regain them.

If I don't restart the computer, it seems to become a problem faster.  Meaning
if I just close FF and restart it, the problem seems to crop back up sooner than
if I reboot the computer.

Sorry, I haven't notied any particular sites that cause a problem, or anything
else that I'm doing that may help.
The only common site I have open is Earthlinks WebMail page, the rest are just
random, normally news sites or "How thigns work".

This problem happens "almost" all the time.  I suspect if I leave it up long
enough I will have the problem everytime.


Also, (another problem) I'v noticed that a lot of times I'll click on a bookmark
in the bookmark window, but the browser just sites there, doesn't go to the
site.  At first I thought it was just me not really clicking on it, but the
bookmark I clicked on has the focus, the cursor in on that book mark.  This too
unfortunantly is pretty random.

Reproducible: Always
Steps to Reproduce:
1. None that I know of, other than open several tabs, say 4 or 5.
2.
3.

Actual Results:  
After a random amount of time, processor usage will increase to 100% (as
indicated by Windows task manager).  Usage will stay there and render computer
usless.

Expected Results:  
Processor usage should increase as the program "does something" then returns
back to normal.

From the Fire Fox "About" window.
Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

Windows 2000, Sp4 128bit encryption.  MS Outlook is normally open.
Also, Nortons internet security is installed.

I wish I could be of more help, if you need anything or have any questions,
please feel free to contact me.
Oh yeah, I noticed this is version .9 (I just recently started using FF).  I
updated to version 1.0 to see if that would correct the problem, and it did not.
 I followed the instructions for using a new director and the switch for
creating a new profile, still no help.  It's common to both versions.
Dang, I forgot to mention, (sorry) when FF is locked up, the Send/Receive lights
for the modem are not blinking, no data is being transmitted or received.  So
it's not sending or receiveing data.
I've been seeing this a lot too in 1.0PR.  One additional data point from my
experience is that it seems that it only happens after I go to standby and then
resume (this is a Dell C610 laptop).  

If it's any help, I've also seen similar behavior (less often) from Thunderbird
0.8.  

I'm generally only running Yahoo! IM, iTunes, and the XDrive background agent. 
 I'm on WinXP SP1.  I think this is a p3-1.2GHz with 512MB.
This website seems to cause the resources to go to 100% on my machine pretty
regular.  There is still no data being transfered, but the resouces are all
locked up.

http://www.foxnews.com/story/0,2933,133877,00.html

One I close this website, resouces normally go back to normal levels.  Open it
again, and zoom!  I haven't tried having just this one page open, but I know if
I open it in another tab, resources will skyrocket.
I too notice the same almost everytime if I have more number of tabs opened in
firefox and if I drop my laptop into standby mode.  The 100% cpu usage is
persistent untill I really close all the tabs and hence firefox after the resume
from standby.  I have IMB T41 laptop running win2k.
I'm seeing the same with FF 1.0.1 on Windows XP, but only after resuming from
standby. It also seems to happen only when I have one or more FF windows with
multiple tabs open.
This seems to be a Java Issue.

If you disable Java from the Tools, Options, Disable Java, the problem will go away.

Re-enable Java, problems comes back.

This web site (Fox News) will cause the problem.
http://www.foxnews.com/story/0,2933,151180,00.html
Duping to bug 275783, as it sounds suspiciously like it.

*** This bug has been marked as a duplicate of 275783 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.