Right mouse click when using TightVNC causes 'duplicate' menus to pop up

RESOLVED DUPLICATE of bug 378424

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 378424
14 years ago
11 years ago

People

(Reporter: CR, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When using firefox to access a remote machine that is being shared with VNC or
TightVNC, a right click on the remote machine's desktop will cause the remote
machine's context menu to appear (as it should) as well as Firefox's context
menu.  Firefox's context menu should not appear.  Apparently, Firefox is
capturing the mouse click even though it is intended to only go to the remote
machine.

This also occurs when using Firefox on Win2k.

Reproducible: Always
Steps to Reproduce:
1. Set up a machine to share its desktop using VNC or TightVNC.
2. Use Firefox to access the remote machine.
3. Right click on the remote machine's desktop.

Actual Results:  
Both the remote machine's context menu and Firfox's context menu are invoked.

Expected Results:  
Only the context menu on the remote machine should appear.

This behavior does not occur when using IE as the browser.

Comment 1

13 years ago
Bug 250753 is the Seamonkey equivalent of this.  Note that what's going on here
is "as designed" in the sense that we're not allowing the remote site to disable
our own context menu.  However, we need to either have some way of making an
exception (so that things like clicking inside a VNC window DOES disable our
context menu) or implementing a whitelist of certain sites that are allowed to
disable our context menu so as to prevent this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
Note: This is a side-effect of the otherwise desirable bug 86193.
Assignee: bross2 → nobody

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378424
You need to log in before you can comment on or make changes to this bug.