favicon.ico request results in 403 errorpage being displayed.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: cn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

A new website we are developing did not have a favicon, and returned a 403
(Authorization Failed) errorcode if it was requested.
After upgrading to Firefox RC, FireFoxt apparantly automatically requests
favicon.ico, and when the request fails, the error response is displayed in the
browser.
This often happen just after logging in (during authentication?)

Reproducible: Sometimes
Steps to Reproduce:
1. Request a (any) page which requires authentication.
2.
3.

Actual Results:  
I get this response (requested page is NOT favicon.ico):

Response Headers - http://xxxxx/favicon.ico
Date: Wed, 22 Sep 2004 09:16:28 GMT
Server: IBM_HTTP_Server/2.0.47 Apache/2.0.47 (Win32)
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html;charset=ISO-8859-1
Content-Language: en-US


Expected Results:  
Displayed the requested page.
Assignee: firefox → vladimir
Status: UNCONFIRMED → NEW
Component: General → Bookmarks
Ever confirmed: true
QA Contact: firefox.general → mconnor
*** Bug 263896 has been marked as a duplicate of this bug. ***
*** Bug 262580 has been marked as a duplicate of this bug. ***
*** Bug 265338 has been marked as a duplicate of this bug. ***
Brought over the test URL from bug 263896 - seems to be the best and most
test-ish of the dups.

Comment 5

14 years ago
The bug appears to still exist in FireFox RC1 V1.0.

Go to https://webapps.mar.med.navy.mil/exchange/logon.asp.  You will see that
you are prompted for login and password when you should not be prompted.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Assignee: vladimir → nobody
Status: ASSIGNED → NEW

Comment 7

10 years ago
WFM with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8.

First I tried with the URL linked to in this bug, but using Live HTTP Headers I see that the page itself at that URL requires authentication.  Tried with http://people.mozilla.com/~adw/bug260927/, examined headers using Live HTTP Headers, indeed the response for the favicon is a 401, but the page loads successfully and the default favicon is used instead.  Must have been fixed somewhere along the way.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.