Getting "reference to undefined property document.write"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
I have no idea why I've started to get invalid warnings like this, but something
must be wrong in the JS engine reporting invalid undefined property.

To reproduce:
1) Turn on strict JS warnings
2: goto http://weba.mail.tdconline.dk/webmail/

You get a couple of correct invalid property warnings but also this one:

Warning: reference to undefined property document.write
Source File: http://i.tdconline.dk/headerfooter/webmail.js
Line: 525

I cant see how this code:
function dw(s){
document.write(s)
}

can produce:
"undefined property"

using firefox latest nightly build. I've started getting these warning a couple
of months ago. We never seen them before.

Is it me or a bug in the JS engine?
This worksforme with a current trunk build... Henrik, are you still seeing this?

Comment 2

14 years ago
I am getting these same messages since I upgraded from Firefox 1.02 to Firefox
1.04 ( Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4 ). It seems that the first reference to the document object in
inline javascript raises a warning like 'reference to undefined property
document.getElementById' or 'reference to undefined property document.write' and
so on.
The javascript itself thereafter seems to execute just fine...
That sounds like a separate issue (recent regression and all).  Could you please
file a new bug on it, attach a page that shows the problem, and cc me?
Assignee: general → nobody
QA Contact: ian → general
404
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.