ctrl+g or F3 (next match for find as you type) does not seem to work anymore

VERIFIED WORKSFORME

Status

()

Firefox
Keyboard Navigation
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Jephe CLAIN, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040920 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040920 Firefox/0.10

When I use find as you type, Ctrl+G and/or F3 does not work to find the next
occurence.
Using the menu Edit/Find again does not seem to work either.

my setup: gentoo linux (so this is firefox built from scratch) with "gnome gtk2"
USEs, running under Gnome 2.6.2 (see the build config below)

Reproducible: Always
Steps to Reproduce:
1.start to type a text to select a link
2.press Ctrl+G
3.

Actual Results:  
nothing (the selection remains on the current link)


Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-march=pentium4 -pipe -pthread -pipe
g++ 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -march=pentium4 -pipe -Wno-deprecated
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --enable-optimize=-O2 --enable-old-abi-compat-wrappers
--disable-activex --disable-activex-scripting --disable-installer
--disable-pedantic --enable-crypto --enable-mathml --enable-xterm-updates
--with-pthreads --with-system-jpeg --with-system-png --with-system-zlib --with-x
--without-system-nspr --disable-ipv6 --enable-ldap --enable-ldap-experimental
--disable-xinerama --enable-xprint --enable-gnomevfs
--enable-default-toolkit=gtk2 --disable-debug --disable-tests --enable-reorder
--enable-strip --enable-strip-libs --enable-elf-dynstr-gc --enable-xft
--enable-freetype2 --enable-freetypetest --disable-jsd --disable-xpctools
--enable-oji --disable-mailnews --disable-calendar --disable-svg
--enable-extensions=cookie,inspector,negotiateauth,pref,transformiix,typeaheadfind,universalchardet,webservices,xmlextras,xml-rpc,gnomevfs
--with-default-mozilla-five-home=/usr/lib/MozillaFirefox --enable-single-profile

Comment 1

13 years ago
I'm sure you check this, but, there is definitely more than 1 match on the page
right? If there's only 1 match it looks like nothing is happening as you hit Ctrl+G.

This is without the find toolbar right? What happens if you type / first and
then use the shortcuts? Also, what happens if you hit / first and then click on
"find next" in the find toolbar?

Comment 2

13 years ago
*** Bug 261028 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
I have the same problem.  I am also running Gentoo but I am using KDE as the WM.  

First off, yes, the search item exists more than once.  If I put "/" first,
ctrl-g and f3 still don't work.  

If I bring up the search bar (ctrl-f) and enter some text (that exists multiple
times) and hit Find Next nothing happens.  It doesn't find the first match or
any subsequent matches.  Find next on the toolbar also never finds the next
occurrence.

Comment 4

13 years ago
So it doesn't work with the find toolbar either.

Have either of you ever set any accessibility.typeaheadfind prefs directly? I
wonder why more people aren't seeing this.
Assignee: aaronleventhal → firefox

Comment 5

13 years ago
I have not changed anything in the about:config (though I have read through it).
 As too the lack of reports, I know my boss (Firefox 1.0PR on Gentoo) has the
same problem.  

Comment 6

13 years ago
1. Is Gentoo the common thread here?
2. Is everyone building their own?

Comment 7

13 years ago
Apparently this is a Gentoo bug:
http://bugs.gentoo.org/show_bug.cgi?id=64196

see also:
http://forums.gentoo.org/viewtopic.php?t=226525&highlight=firefox
http://forums.gentoo.org/viewtopic.php?t=225617&highlight=firefox

I haven't verified it yet, but the Gentoo binary version is suppose to work
fine.  All the bad firefox installs with problems we had were built from ebuilds
(source).

Thanks for your help!

Comment 8

13 years ago
Gentoo-only problem. Being taken care of by that project.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
also w4m (but am using fedora core 2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.