Bookmark Dropdown Menu closes upon first click after startup if not given focus

VERIFIED DUPLICATE of bug 252412

Status

()

Firefox
Bookmarks & History
--
minor
VERIFIED DUPLICATE of bug 252412
14 years ago
12 years ago

People

(Reporter: Casey Weston, Assigned: vlad)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040921 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040921 Firefox/0.10

The Bookmark Dropdown Menu closes immediately after it is clicked if the mouse
cursor is not over the dropdown portion of the menu.  No other Menus react in
this manor. Only occurs upon fresh startup of browser.

Reproducible: Always
Steps to Reproduce:
1. Make sure all firefox browsers are closed and open a fresh one.
2. Click on Bookmarks on the menu and leave the cursor on the words Bookmarks.
3. Wait 1-2 seconds.

Actual Results:  
The Bookmark Dropdown Menu will close immediately and you will have to click it
just to give it focus and then click it again to open it.  After that it works
normally.

Expected Results:  
Bookmark Dropdown Menu remains open.

I believe it could be that in the condition when Bookmarks is clicked there are
missing statements which tell the menu to stay put unless the mouse clicks
elsewhere.

I find this bug annoying in that when I click my Bookmarks I wait til I can see
what I want to click and not pick right away. But this bug makes me click it
again.  Frustrating.
(Reporter)

Updated

14 years ago
Version: unspecified → 1.0 Branch

Updated

14 years ago
Assignee: firefox → vladimir
Component: Menus → Bookmarks
QA Contact: bugzilla → mconnor
Do you have any Live Bookmarks? If so, this is a dup of bug 252412
No response, assuming it's a dup of the Live Bookmarks problem.

*** This bug has been marked as a duplicate of 252412 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.