lazboy.com - Javascript for changing fabrics fails due to bad reference

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Mike Palumbo, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

If you look at the URL
http://www.lazboy.com/ourfurniture/furniture_detail.asp?furnitureid=1122, you'll
see that trying to switch the fabric swatches results in a javascript error on
the console:
Error: Fabricnumber is not defined.

This error happens in the following file:
http://www.lazboy.com/scripts/sceneseven.js

The bad line is:
fabricnumber.innerHTML = strFabricNumber;

Simply correcting the line to document.fabricnumber.innerHTML would fix it.

This code is only used for the "Flyer" line of couches, as stated in the
javascript comments: // This is only used for the flyers.



Reproducible: Always
Steps to Reproduce:
1. Go to the main URL referenced in this bug.
2. Try to click on one of the different fabric swatches.
3. Check the JS Console.

Actual Results:  
Error on the console, new fabric doesn't appear.

Expected Results:  
It should have shown the new fabric type that you clicked on.

Comment 1

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new

Reporter, next time you file a TE bug, please follow the guidelines.
Summary: Javascript for changing fabrics fails due to bad reference → lazboy.com - Javascript for changing fabrics fails due to bad reference

Comment 2

10 years ago
Looks FIXED to me.

http://www.la-z-boy.com/furniture/customize.aspx?pid=4951

works great in both Firefox 2 and Camino trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.