SeaMonkey / mozilla asks for another profile if already ran and run-mozilla.sh is in the libdir

RESOLVED FIXED

Status

SeaMonkey
Build Config
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Eric Piel, Unassigned)

Tracking

({fixed-seamonkey1.0, fixed1.8.0.1, fixed1.8.1})

Trunk
x86
Linux
fixed-seamonkey1.0, fixed1.8.0.1, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040919 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040919 Firefox/0.10

In firefox 0.10 the script to run firefox (mozilla.in) checks if there is
already an instance of the program present and then it uses
mozilla-xremote-client. This does work excepted if run-mozilla.sh is in the
libdir (/usr/lib/mozilla-firefox-0.10). The following patch resolves the problem.

Reproducible: Always
Steps to Reproduce:
1. do not have /usr/bin/run-mozilla.sh , keep it in /usr/lib/mozilla-firefox-0.10
2. mozilla-firefox http://www.mozilla.org&
3. mozilla-firefox http://www.google.org&


Actual Results:  
Firefox ask for a profile.

Expected Results:  
Firefox should open a new window.
(Reporter)

Comment 1

13 years ago
Created attachment 159743 [details] [diff] [review]
finds the run-mozilla.sh even when it is in /usr/lib/mozilla-firefox-0.10/

Let's note that the script is yet not optimal. In particular the remote
communication are done with ${progbase}. Therefore if the script is called
anything else than "firefox", "mozilla" or "thunderbird" it will fail. On
mandrake this script is called "mozilla-firefox" and everything is broken :-(
Assignee: general → bryner
Component: Browser-General → Build Config
Product: Browser → Firefox
QA Contact: general → asa
Summary: mozilla asks for another profile if already ran and run-mozilla.sh is in the libdir → firefox asks for another profile if already ran and run-mozilla.sh is in the libdir

Comment 2

13 years ago
I think that the $moz_libdir value should be defined when installing. For
example, you install Firefox at /usr/share/firefox-1.0 then the script is
generated during the installation with:
moz_libdir="/usr/share/firefox-1.0".
Also, why bother with ${progbase}? The binary for firefox is always firefox-bin
in the installation directory so it should be hardcoded in the script.

Comment 3

12 years ago
Is this related to Bug 253946?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Is this related to Bug 253946?

No, the bug that you point is about being able to run several time mozilla in
the same time. On the contrary this bug is about mozilla which doesn't detect
correctly the other instance.

Actually I wonder if this bug is still valid. At least on Mandriva, the
run-mozilla.sh script is clever enough to find everything necessary.

Comment 5

12 years ago
This issue has been discovered independently by others (Firefox 1.0.6), arriving
at the exact same one-line patch that is already attached.  The bug will remain
in releases unless the attached patch is applied.  Please consider committing it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 159743 [details] [diff] [review]
finds the run-mozilla.sh even when it is in /usr/lib/mozilla-firefox-0.10/

As this patch is still relevant (at least something like this isn't in trunk), requesting review on the reporter's belated behalf.
Attachment #159743 - Flags: review?(benjamin)
Comment on attachment 159743 [details] [diff] [review]
finds the run-mozilla.sh even when it is in /usr/lib/mozilla-firefox-0.10/

This patch should be applied to xpfe/bootstrap/mozilla.in

I don't think it is needed or should be used in the toolkit apps.
Attachment #159743 - Flags: review?(benjamin) → review+
Assignee: bryner → nobody
Component: Build Config → Build Config
Flags: review+
Product: Firefox → Mozilla Application Suite
QA Contact: asa → build-config
(because the toolkit apps now use the auto-remoting architecture)
Comment on attachment 159743 [details] [diff] [review]
finds the run-mozilla.sh even when it is in /usr/lib/mozilla-firefox-0.10/

As :bs changed the product, silly Bugzilla dropped the review+. Bringing it over.
Attachment #159743 - Flags: review+

Updated

12 years ago
Summary: firefox asks for another profile if already ran and run-mozilla.sh is in the libdir → SeaMonkey / mozilla asks for another profile if already ran and run-mozilla.sh is in the libdir

Comment 10

12 years ago
Created attachment 206342 [details] [diff] [review]
Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

Carrying forward r=
Attachment #159743 - Attachment is obsolete: true
Attachment #206342 - Flags: review+

Comment 11

12 years ago
Comment on attachment 206342 [details] [diff] [review]
Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

Checking in
mozilla.in;
new revision: 1.10; previous revision: 1.9
done
Attachment #206342 - Attachment description: Unbitrotted patch for trunk → Unbitrotted patch for trunk (Checked in)
Comment on attachment 206342 [details] [diff] [review]
Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

seems like this'd be nice for 1.0final
Attachment #206342 - Flags: approval-seamonkey1.0?

Comment 13

12 years ago
Comment on attachment 206342 [details] [diff] [review]
Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

a=me

Updated

12 years ago
Attachment #206342 - Flags: approval-seamonkey1.1+
Attachment #206342 - Flags: approval-seamonkey1.0?
Attachment #206342 - Flags: approval-seamonkey1.0+

Comment 14

12 years ago
Comment on attachment 206342 [details] [diff] [review]
Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

Checking in (branch 1.8)
mozilla.in;
new revision: 1.8.8.2; previous revision: 1.8.8.1
done
Checking in (branch 1.8.0)
mozilla.in;
new revision: 1.8.8.1.2.1; previous revision: 1.8.8.1
done
Attachment #206342 - Attachment description: Unbitrotted patch for trunk (Checked in) → Unbitrotted patch(Checked in trunk/branch 1.8 & 1.8.0)

Updated

12 years ago
Whiteboard: fixed-seamonkey1.0

Updated

12 years ago
Keywords: fixed1.8.0.1, fixed1.8.1
Keywords: fixed-seamonkey1.0
Whiteboard: fixed-seamonkey1.0

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.