Unable to drag and drop Bookmarks Toolbar Folder in BM manager

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Jeremy M. Dolan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Firefox 0.10. Unable to drag and drop the Bookmarks Toolbar Folder in BM manager.
Can not drop it into the left pane or right pane. Reassigning the BTF property
to another folder allows the old BTF to be moved as normal.

During the drag, feedback is normal (user is shown the "will insert here"
divider), but the move does not actually execute once you release the mouse button.

Same problem if you select multiple folders, one of them being the BTF. None of
them will be moved upon drag release.
Assignee: vladimir → vladimir+bm

Comment 1

13 years ago
Is bug 263560 a dupe of this one?

Prog.
*** Bug 301290 has been marked as a duplicate of this bug. ***
Since the bookmarks toolbar folder cannot be deleted, the recommended workaround
is just to treat it like any other bookmarks folder. This bug obviously causes
problems with this.
Assignee: vladimir+bm → nobody

Comment 4

12 years ago
As a workaround, you can highlight a group of other folders and move them in the opposite direction "around" the BTF, allowing it to be "moved" to the bottom of the list or whatever.

Comment 5

12 years ago
Happens on Windows too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060615 BonEcho/2.0a3 - Build ID: 2006061503
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081219 Minefield/3.2a1pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.