Firefox "Forgets" Element Class Name

RESOLVED DUPLICATE of bug 261074

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 261074
13 years ago
13 years ago

People

(Reporter: Jerry Baker, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Firefox "forgets" the current className of an object when a window is minimized
and restored. Load the example page attached and minimize and restore it. When
focused, it should have an input element with a black background, and when
blurred it should have a white background. If you keep minimizing and restoring
it, you'll see that Firefox alternates the state.
(Reporter)

Comment 1

13 years ago
Created attachment 159751 [details]
Example

If you minimize and restore this test page several times, you will see exactly
what I am describing.
(Reporter)

Comment 2

13 years ago
Created attachment 159761 [details]
Working

If you use the exact same script, but a slightly different method, the issue
does not occur. Perhaps a timing issue assigning the className many times (the
onfocus and onblur events fire many times each time the window is
restored/minimized)???
(Reporter)

Comment 3

13 years ago
Ok. Here's why. When you minimize the window, the following events are fired:

onblur
onblur
onfocus
onblur
onblur
onfocus

Firefox's events are royally hosed.

Comment 4

13 years ago
Same happening in mozilla suite, product should be changed to Browser
(Reporter)

Comment 5

13 years ago
This is being caused by Forefox's broken onfocus event.

*** This bug has been marked as a duplicate of 261074 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.