If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ESPN RSS Feeds Fail To Load

VERIFIED DUPLICATE of bug 253911

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 253911
13 years ago
11 years ago

People

(Reporter: Matt Cosentino, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10

I'm able to create a Live Bookmark from the ESPN site, but the feed fails to
load when I try to open it.

Reproducible: Always
Steps to Reproduce:
1. Go to ESPN.com
2. Subscribe to RSS feed
3. Try to open Live Bookmark

Actual Results:  
"Live Bookmark feed failed to load."

Expected Results:  
Feed should load and items should be displayed as bookmarks.
Open Bookmarks -> Manage Bookmarks -> File -> New Live Bookmark
Copy the feed url (http://sports.espn.go.com/espn/rss/news) into the feed
location input and press ok.

->DUPE


*** This bug has been marked as a duplicate of 255637 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
(In reply to comment #1)
> Open Bookmarks -> Manage Bookmarks -> File -> New Live Bookmark
> Copy the feed url (http://sports.espn.go.com/espn/rss/news) into the feed
> location input and press ok.
> 
> ->DUPE
> 
> 
> *** This bug has been marked as a duplicate of 255637 ***

I don't see how this is a duplicate of that bug.  That bug is for feeds that
don't have a <link> tag but do have an <a> tag to their feeds.  ESPN does have a
link tag which allows for subscribing using the status bar button.  Also adding
the feed manually as stated above still results in a livemark which is unable to
load.  

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922
Firefox/0.10
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> Open Bookmarks -> Manage Bookmarks -> File -> New Live Bookmark
> Copy the feed url (http://sports.espn.go.com/espn/rss/news) into the feed
> location input and press ok.
> 
> ->DUPE
> 
> 
> *** This bug has been marked as a duplicate of 255637 ***

What?  Did you even read my description?  This has nothing to do with that.  I
was able to create the Live Bookmark, this is a parsing error.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Also seeing this with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040923
Firefox/0.10

As a side note, it works with Thunderbird and the Sage extension
Hard to tell without knowing the details of the format and Firefox's code both,
but this is actually a dup of bug 253911 (which has a patch, and should be fixed
soon).
(Reporter)

Comment 6

13 years ago
I don't see how this is a dup of 253911, that bug is for CDATA blocks in 0.91
feeds.  This is a 2.0 feed and there are no CDATA blocks.
View - Page Source. The titles are all in CDATA blocks, so we currently don't
see any titles, so we don't find any items. Since our parser is only looking for
item/title and item/link (or item/guid), there's really no difference between
0.91 and 2.0 to us: everything that isn't 1.0/RDF gets parsed the same.
(Reporter)

Comment 8

13 years ago
Oh ok, I was confused because it didn't show the CDATA blocks in the formatted
XML.  

*** This bug has been marked as a duplicate of 253911 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.