Closed Bug 261008 Opened 15 years ago Closed 14 years ago

Message editor interface in WYSIWYG not functional when posting messages

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: silverstar28, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

This forum has a message editor interface in WYSIWYG mode (Enhanced mode) when
posting messages. However, when using Firefox 1.0PR, this feature is not
available. When using Firefox 0.9 and older I am able to use this feature.

Reproducible: Always
Steps to Reproduce:
1.First, must be registered
2.Click on "New Thread"
3.And switch to "Enhanced Mode" in the editor
4.Editor should now be viewed in WYSIWYG mode (white screen).

Actual Results:  
When switching to "Enhanced Mode" nothing happens, the editor stays in black screen.

Expected Results:  
Editor should have switched to WYSIWYG mode (white screen) where images and text
formats can be viewed.

I am using "Single Window 1.4" and Noia 2.0 (eXtreme) theme. I want to point out
that this was happening before I installed the extension and theme.
I just wanted to add a comment about this.  I experience this at 
http://www.christianforums.com when using Mozilla Firefox 1.0 Preview 
Release.  Basically, Christian Forums has a WYSIWYG interface for posting 
messages on Christian Forums.  They have smileys that you can insert into the 
post and general text editing.  When you click a smiley to put it in your 
post, it will go directly into the text box and you can see the graphical 
smiley normally.  However, with Firefox 1.0 Preview Release, you can't.  
Instead, it puts the code for that particular smiley.  While editing text, if 
you hit one of the text formatting buttons such as Bold, Italics, or 
Underline, it will normally show the formatted text as already formatted in 
the text box.  However, with Firefox 1.0 Preview Release, it puts the HTML 
code for that format in the text box rather than showing it as already 
edited.  Once you hit the submit button and your post is already in the 
thread, everything appears normally.  This bug only occurs when doing a reply 
or a new post in the WYSIWYG editor, not Quick Reply.  This bug is 
reproduceable.  Hope this helps you guys get it fixed!
Same thing. I can't use FireFox in my site because of the same reason. The
WYSIWYG editor area appears disabled.
WYSIWYG editors do not seem to work in 1.0PR with any BBs running vBulletin
Version 3.0.1.

Was working fine in previous FF-releases.

This is a bug that does not affect FF1.0PR on W2K but only on XP SP2.
Even creating a new profile does not resolve this problem in XP SP2.
It also doesn't work on vB 3.0.3

If you don't believe me, go to http://forums.kyletech.us - running completely on
vB 3.0.3
I basically cannot use WYSIWYG editors on any site that has them.  My blog
service, Typepad.com offers a wonderful rich text editor & trying to use it
caused huge barrels of grief. I would create a post using that editor & hit the
publish button & the entire post would disappear.  I would try to format a word
& click preview or post & the formatting would evaporate as if I'd never
formmated the word at all.

I've found similar problems with http://democrats.com/forum and
http://forum.mamboserver.com/ .  None of the wysiwyg editors at these sites will
work w. FF 1.0.  There's one helluva serious problem here and not enough
priority is being given to solving it.  I post about this problem in the FF
forum & no one replies.  Frustrating!
The WYSIWYG Editors uesd by the open-source CMS Systems Joomla and Mambo are not
useable, too. This bug can be reproduced both using current nightly builds of
Firefox AND Camino (MacOS X)
To check this out, simply log in at the joomla demo site (demo.joomla.org),
click on add new content and you'll see!
The Midas component seems to work fine for me (Trunk: 2005111805) using this example: http://www.mozilla.org/editor/midasdemo/

Is this a Tech Evangelism bug or a FF one? The Mozillazine forums don't seem to have an Enhanced mode that I can find to test it on.
There are WYSIWYG editors that work very nice with latest Firefox like http://tinymce.moxiecode.com/example_full.php?example=true and http://www.fckeditor.net/demo/default.html so this is probably a Tech Evangelism issue with each of those sites, not a Firefox problem.
HTMLArea works fine on 1.0/1.5 Windows XP SP2.
http://www.dynarch.com/demos/htmlarea/examples/core.html

I would suggest that anyone with problems contact the authors of the html editors and let them know about the problem, and point them to this bug. If there really is a problem in FireFox they will come here with proof. (Authors can be fanatical about their software!)

In the long run this will get more done for you guys than anything else. Mozilla isn't going to have time to look through every single html editor out there and look for problems.

This bug has become a general dumping ground where people are complaining about a number of sites not working with Firefox, the vast majority of which are likely because of browser-specific coding practices. Bugs should be filed for individual issues, in most cases against the "Tech Evangelism" product so that the faulty sites can be contacted to describe what they're doing wrong and hopefully so that they correct it. Marking invalid, please file new bugs on individual issues.
Assignee: firefox → nobody
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
For Joomla, created as #317725
You need to log in before you can comment on or make changes to this bug.