All users were logged out of Bugzilla on October 13th, 2018

IE migration deletes contents of Bookmarks Toolbar Folder

RESOLVED DUPLICATE of bug 387137

Status

()

--
critical
RESOLVED DUPLICATE of bug 387137
14 years ago
11 years ago

People

(Reporter: tracy, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Seen on Firefox Windows build 2004-09-22-08-0.9+

-delete the Firefox folder in Application Data\Mozilla
-launch Firefix: the Import Wizard should appear.
-Select IE and run import

tested results: When Firefox opens, notice that the Bookmakrs Toolbar is empty.

expected results:  The Bookmarks toolbar contains the two installation default
bookmarks.
(Reporter)

Comment 1

14 years ago
note:  File | Import of IE setting does not delete the Bookmarks Toolbar items.
Assignee: bugs → nobody
From the code, I get the impression this was done on purpose.
See:
http://lxr.mozilla.org/seamonkey/source/browser/components/migration/src/nsIEProfileMigrator.cpp#411
On first start, aReplace is set to true. Then, the code is deleting the existing stuff based on that, see:
http://lxr.mozilla.org/seamonkey/source/browser/components/migration/src/nsIEProfileMigrator.cpp#1410
http://lxr.mozilla.org/seamonkey/source/browser/components/migration/src/nsIEProfileMigrator.cpp#1159
So my guess is that when you set aReplace to false always, this bug would go away.
But I'm not sure if that should be happening.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387137
You need to log in before you can comment on or make changes to this bug.