Information bar suggests adding wrong domain to XPI whitelist

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: staale, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

When trying to install an extension from update.mozilla.org, firefox reports
that update.mozilla.org is the domain trying to install software, while in
reality, ftp.mozilla.org in this case is the real domain.

This will result in the plugin will not be installed, when only
update.mozilla.org is in the 'allowed sites' list. When I added ftp.mozilla.org
to the list, install dialog/window poped up and installation went fine.

Please see attached screenshot about how Firefox detects the domain wrong about
the site trying to install software/extensions.

Screenshot: http://shortgeek.com/tmp/ff.png

Reproducible: Always
Steps to Reproduce:
[got comment that this may be related to https, if you have visited a page with
https before going to update.mozilla.org]

1. http://update.mozilla.org/extensions/moreinfo.php?id=10
2. Click on "Install now" Site will be blocked
3. Firefox reply that update.mozilla.org is blocked.

Actual Results:  
If adding update.mozilla.org to allowed domains as firefox sugest, you are still
unable to install the extension, because the real domain is ftp.mozilla.org

Expected Results:  
Detecet ftp.mozilla.org as domain trying to install extension, instead of
update.mozilla.org
(Reporter)

Comment 1

14 years ago
Duplicate of bugg #261025, only differce is that #261026 has url to screenshot
included.

Comment 2

14 years ago
*** Bug 261025 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Component: General → Extension/Theme Manager
Summary: detects wrong domain in "allow domain to install software" → Information bar suggests adding wrong domain to XPI whitelist
Do you have referrers turned off? WFM, but this could happen if there are no
referrers.
No response, WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
See also bug 257055.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.