plugin finder offers to install Java despite Java being installed, but disabled in Web Features

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
5 years ago

People

(Reporter: robert, Assigned: doronr)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
If Java is installed, but disabled in the Options panel in Firefox, the new
plugin installer says that it needs to install missing plugins on pages that use
java.

If Java is disabled, it should not offer to install the Java plugin, preferably
whether it is installed or not.  However, it definitely should not offer to
install Java if it is installed but simply disabled.
(Reporter)

Updated

15 years ago
Flags: blocking-aviary1.0?

Comment 1

15 years ago
reporter: please be nice and provide a url which demonstrates this problem.
(Reporter)

Comment 2

15 years ago
Any web site using Java will show this, but here's a URL for ease of testing.
(Assignee)

Comment 3

15 years ago
I wouldn't call this a 1.0 blocker since disabling java is a advanced user thing.
(Reporter)

Updated

15 years ago
Flags: blocking-aviary1.0?
*** Bug 261168 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Component: General → Plugin Finder Service

Updated

15 years ago
Keywords: polish
QA Contact: firefox.general → firefox.plugin.finder
Summary: New plugin installer offers to install Java if it is installed, but disable in the Options panel → plugin finder offers to install Java despite Java being installed, but disabled in Web Features
Product: Firefox → Toolkit
I suspect this ancient bug is no longer valid. Feel free to reopen if I'm mistaken.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.